1
plecavalier
successful login but no rights
  • 2008/5/21 19:55

  • plecavalier

  • Just popping in

  • Posts: 2

  • Since: 2008/5/21


Hi,

I don't know much about XOOPS and MySQL but I've been asked to fix the following problem:

When you log in with the administrator account XOOPS displays the successfully logged in message and bring me back to the homepage which is normal for this install. However, there is no more link for "Administration Menu" so it seems like the Administrator account no longer has admin rights.

The exact same thing happens when I log in to perform the MUCH needed upgrade to 2.18.1. I login and it brings me right back to the login page with no errors.

Anybody ever see this?

2
suisss
Re: successful login but no rights
  • 2008/5/21 20:01

  • suisss

  • Just popping in

  • Posts: 45

  • Since: 2004/6/20



3
plecavalier
Re: successful login but no rights
  • 2008/5/21 23:54

  • plecavalier

  • Just popping in

  • Posts: 2

  • Since: 2008/5/21


If I do that I get "You don't have the right to access this area".

4
mboyden
Re: successful login but no rights
  • 2008/5/22 14:55

  • mboyden

  • Moderator

  • Posts: 484

  • Since: 2005/3/9 1


You will need to make sure that the Administrator is in the admin group. In the xoopsprefix_groups_users_link table, make sure there is an entry for your administrator with the following values:
groupid: 1
uid: 1
This assumes your Administrator account still is uid of 1 (you can check the xoopsprefix_users table to find out), and then the groupid of 1 is the Administrators group.

Clear as mud? If that checks out and you're still having problems, then turn on debugging (see the Debug link in my sig) and see if that gives more info.
Pessimists see difficulty in opportunity; Optimists see opportunity in difficulty. --W Churchill

XOOPS: Latest | Debug | Hosting and Web Development

5
stomper
Re: successful login but no rights
  • 2008/5/23 10:23

  • stomper

  • Just popping in

  • Posts: 4

  • Since: 2008/5/23


I'm having the same problem! It seems to be the same for all users, not just the admins. After login in you still get the 'thank you for login in' msg, but remain logged out - no admin menu or rights. The only way i found of login in was using the fast reply in the forum. I posted on the forum as admin using fast reply to get logged in in this way and now I can access the back end.

I recently updated from PHP4 to PHP5

6
netmgr
Re: successful login but no rights
  • 2008/5/24 20:23

  • netmgr

  • Just popping in

  • Posts: 2

  • Since: 2008/5/24


looks like youve got a bug, because im getting the same problem on a brand new install...

7
stomper
Re: successful login but no rights
  • 2008/5/26 10:41

  • stomper

  • Just popping in

  • Posts: 4

  • Since: 2008/5/23


Quote:

If that checks out and you're still having problems, then turn on debugging (see the Debug link in my sig) and see if that gives more info.


Your debug link doesn't work :)

8
mboyden
Re: successful login but no rights
  • 2008/5/26 14:13

  • mboyden

  • Moderator

  • Posts: 484

  • Since: 2005/3/9 1


I've fixed the link. All it does is take you to the debugging FAQ category. But the info there is helpful, especially turning on the debugging to get error messages (look at both php and mySQL errors, as both may provide insight).

As to the link in my sig, something changed on the site with the way that the XOOPS Codes (bbcode) interprets relative URLs (I was using relative URLs because of the limited space for this field (which stores it, but truncates it upon display). It must be a change between .16 and .17 because site relative URLs used to work. I'll have to look into that further.
Pessimists see difficulty in opportunity; Optimists see opportunity in difficulty. --W Churchill

XOOPS: Latest | Debug | Hosting and Web Development

9
stomper
Re: successful login but no rights
  • 2008/5/27 12:41

  • stomper

  • Just popping in

  • Posts: 4

  • Since: 2008/5/23


I've run the site in debugging mode, but only get a few module specific errors - nothing that I see could cause this login issue.

Does anyone have any suggestions to a solution?

Basically if a user tries to log in through any of the sitewide login boxes or at the user.php page, they are told "Thank You for logging in" then redirected back to the site not logged in.

The only way I can find to remain logged in is by using the Fast Reply form in the forum which uses this method:

<form name='quick_reply' id='quick_reply' action='post.php' method='POST' onsubmit='return xoopsFormValidate_quick_reply();'>


Curiously once you have successfully logged in by this method, all the other login boxes work correctly and you can log in and out freely.

10
trabis
Re: successful login but no rights
  • 2008/5/27 12:46

  • trabis

  • Core Developer

  • Posts: 2269

  • Since: 2006/9/1 1


Quote:

stomper wrote:
I'm having the same problem! It seems to be the same for all users, not just the admins. After login in you still get the 'thank you for login in' msg, but remain logged out - no admin menu or rights. The only way i found of login in was using the fast reply in the forum. I posted on the forum as admin using fast reply to get logged in in this way and now I can access the back end.

I recently updated from PHP4 to PHP5


Your case is diferent. Repair you sessions table, 90% chances it is crashed.

Login

Who's Online

83 user(s) are online (50 user(s) are browsing Support Forums)


Members: 0


Guests: 83


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits