xoops forums

tzvook

Just can't stay away
Posted on: 3/17 21:29
tzvook
tzvook (Show more)
Just can't stay away
Posts: 872
Since: 2003/2/1 2
#21

Re: Time for an upgrade/update host no longer supporting older php

10. New links waiting for approval ( Admin side = /weblinks/admin/modify_list.php?op=list_new ) result in Error :
Error : ArgumentCountError: Too few arguments to function happy_linux_page_frame::_show(), 0 passed in .../modules/weblinks/admin/modify_list.php on line 274 and at least 1 expected

tzvook

Just can't stay away
Posted on: 3/17 23:03
tzvook
tzvook (Show more)
Just can't stay away
Posts: 872
Since: 2003/2/1 2
#22

Re: Time for an upgrade/update host no longer supporting older php

11. Links Check when refreshed ( Admin side = /modules/weblinks/admin/link_check_manage.php ) result in Error :
Error : ArgumentCountError: Too few arguments to function admin_link_check_manage::_print_form(), 0 passed in .../modules/weblinks/admin/link_check_manage.php on line 241 and exactly 2 expected

Mamba

Moderator
Posted on: 3/18 13:00
Mamba
Mamba (Show more)
Moderator
Posts: 10883
Since: 2004/4/23
#23

Re: Time for an upgrade/update host no longer supporting older php

Thanks for the testing and reporting.

I've made some changes and uploaded them to the "classic" branches:

https://github.com/mambax7/weblinks/tree/classic
https://github.com/mambax7/happylinux/tree/classic
https://github.com/mambax7/rssheadline/tree/classic
https://github.com/mambax7/rssc/tree/classic

Just click for each of them on the green button on the right "Clone or download" and select "Download ZIP"

Then copy the files to your XOOPS installation.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

tzvook

Just can't stay away
Posted on: 3/18 16:17
tzvook
tzvook (Show more)
Just can't stay away
Posts: 872
Since: 2003/2/1 2
#24

Re: Time for an upgrade/update host no longer supporting older php

Seems that all bugs were crushed ... I'll continue checking in the next few days ..
I'm checking in a 14,000 link directory with 600 categories and 4000 feeds

Mamba

Moderator
Posted on: 3/18 16:26
Mamba
Mamba (Show more)
Moderator
Posts: 10883
Since: 2004/4/23
#25

Re: Time for an upgrade/update host no longer supporting older php

Quote:
14,000 link directory with 600 categories and 4000 feeds

Wow! Now I understand why you were so keen on fixing these modules!
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

tzvook

Just can't stay away
Posted on: 3/18 16:45
tzvook
tzvook (Show more)
Just can't stay away
Posts: 872
Since: 2003/2/1 2
#26

Re: Time for an upgrade/update host no longer supporting older php

Quote:

Mamba wrote:
Quote:
14,000 link directory with 600 categories and 4000 feeds

Wow! Now I understand why you were so keen on fixing these modules!


I have 2 of those... and this is the smallest
It's working since ~ 2004

Mamba

Moderator
Posted on: 3/18 18:38
Mamba
Mamba (Show more)
Moderator
Posts: 10883
Since: 2004/4/23
#27

Re: Time for an upgrade/update host no longer supporting older php

We need more stories like this - it's the best advertisement for XOOPS!
Straight from our happy users!!!
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

tzvook

Just can't stay away
Posted on: 3/19 11:12
tzvook
tzvook (Show more)
Just can't stay away
Posts: 872
Since: 2003/2/1 2
#28

Re: Time for an upgrade/update host no longer supporting older php

Hi Mamba
2 more errors:

in Some of the links extended page (seems the ones that use maps of , but I'm not sure) there were 2 errors

ErrorCall to undefined function split() in file /modules/happy_linux/class/magpie/magpie_parse.php line 183


FIX: /modules/happy_linux/class/magpie/magpie_parse.php line 183
From:
[$ns$el] = split(':'$element2);

To:
[$ns$el] = explode(':'$element2);


That fixed my problems, but probably this error should also taken into account:

Class 'XoopsTree' is deprecatedcheck 'XoopsObjectTree' in tree.php trace: class/xoopstree.php:49
/modules/weblinks/class/weblinks_category_basic_handler.php:98
/modules/happy_linux/include/functions.php:89
/modules/weblinks/include/functions.php:22
/modules/weblinks/class/weblinks_link_count_handler.php:58
/modules/weblinks/class/weblinks_cat_view_handler.php:37
/modules/weblinks/class/weblinks_link_view_handler.php:112
/modules/happy_linux/include/functions.php:89
/modules/weblinks/include/functions.php:22
/modules/weblinks/class/weblinks_singlelink.php:85
/modules/weblinks/class/weblinks_singlelink.php:106
/modules/weblinks/singlelink.php:67

Mamba

Moderator
Posted on: 3/19 17:48
Mamba
Mamba (Show more)
Moderator
Posts: 10883
Since: 2004/4/23
#29

Re: Time for an upgrade/update host no longer supporting older php

Thanks for the testing and fixes, I just uploaded them to GitHub in the "classic" branch

The 'Class 'XoopsTree' is deprecated' notification is just an info for the developers, but there are no problems with it - it will work just fine. But in the future we'll need to switch to XoopsObjectTree...
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

heh26

Just popping in
Posted on: 3/21 9:44
heh26
heh26 (Show more)
Just popping in
Posts: 15
Since: 3/2 15:37
#30

Re: Time for an upgrade/update host no longer supporting older php

Parse error: syntax error, unexpected '=' in /home/heh26/domains/********-xxxx.pl/public_html/modules/happy_linux/class/time.php on line 69
Call Stack
# Time Memory Function Location
1 0.0008 267256 {main}( ) .../index.php:0
2 0.0013 305912 include_once( '/home/heh26/domains/mierzeja-wislana.cal24.pl/public_html/modules/weblinks/admin/admin_header_min.php' ) .../index.php:49


I get this message, what should you change to make the module work normally?