xoops forums

alain01

Quite a regular
Posted on: 2014/4/10 14:04
alain01
alain01 (Show more)
Quite a regular
Posts: 328
Since: 2003/6/20
#1

XOOPS 2.6 : trouble installation and pre-required ?

Hi,
i wanted to install XOOPS 2.6 from github in a wamp installation.

Apache : 2.4.4
MySQL : 5.6.12
PHP : 5.4.16

I downloaded composer as i read in the README.md file.
Quote:
To install this version you will need Composer. You can get it
here: http://getcomposer.org/

From the htdocs/xoops_lib folder run:

composer install

if you are installing for the first time. Otherwise run:

composer update

This should download some required libraries that XOOPS depends on.

But for WAMP (Windows), i tried to install the Composer-Setup.exe.
The program ask me to find the php.exe then i get this message :
Quote:
Some settings on your machine make Composer unable to work properly.
Make sure that you fix the issues listed below and run this script again:

The openssl extension is missing, which means that secure HTTPS transfers are impossible.
If possible you should enable it or recompile php with --with-openssl

Apache modules : ssl_module enabled
php extensions : php_openssl

Can you help me ?

Mamba

Moderator
Posted on: 2014/4/10 15:38
Mamba
Mamba (Show more)
Moderator
Posts: 10828
Since: 2004/4/23
#2

Re: XOOPS 2.6 : trouble installation and pre-required ?

On Windows install Composer using this tool:

https://github.com/johnstevenson/composer-setup

It's the best way!

Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

alain01

Quite a regular
Posted on: 2014/4/10 23:29
alain01
alain01 (Show more)
Quite a regular
Posts: 328
Since: 2003/6/20
#3

Re: XOOPS 2.6 : trouble installation and pre-required ?

Hummmm...
I should make an exe file ?

I dont know what i should do...

Mamba

Moderator
Posted on: 2014/4/11 6:47
Mamba
Mamba (Show more)
Moderator
Posts: 10828
Since: 2004/4/23
#4

Re: XOOPS 2.6 : trouble installation and pre-required ?

Quote:
I should make an exe file ?
I dont know what i should do...

No, no, no!

There was a link there to a download section! Just download the Setup exe file and run it on your windows. That will setup your Composer, and you can continue with the XOOPS 2.6.0 installation.

Just watch my Video in detail and follow the instructions from here:
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

alain01

Quite a regular
Posted on: 2014/4/11 20:34
alain01
alain01 (Show more)
Quite a regular
Posts: 328
Since: 2003/6/20
#5

Re: XOOPS 2.6 : trouble installation and pre-required ?

Since my 1st Post in this topic, i did it !!!

I used "WAMPSERVER (64 BITS & PHP 5.4) 2.4" on my W7 64b pro.

I get the same message after located my php.exe program during composer installation :
Quote:
Some settings on your machine make Composer unable to work properly.
Make sure that you fix the issues listed below and run this script again:

The openssl extension is missing, which means that secure HTTPS transfers are impossible.
If possible you should enable it or recompile php with --with-openssl

Mamba

Moderator
Posted on: 2014/4/11 22:56
Mamba
Mamba (Show more)
Moderator
Posts: 10828
Since: 2004/4/23
#6

Re: XOOPS 2.6 : trouble installation and pre-required ?

Quote:
The openssl extension is missing, which means that secure HTTPS transfers are impossible.
If possible you should enable it or recompile php with --with-openssl

Make sure that you have OpenSSL extensions enabled in PHP.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

alain01

Quite a regular
Posted on: 2014/4/11 23:37
alain01
alain01 (Show more)
Quite a regular
Posts: 328
Since: 2003/6/20
#7

Re: XOOPS 2.6 : trouble installation and pre-required ?

My 1st Post Quote:

alain01 wrote:
Apache modules : ssl_module enabled
php extensions : php_openssl enabled

Mamba

Moderator
Posted on: 2014/4/12 0:52
Mamba
Mamba (Show more)
Moderator
Posts: 10828
Since: 2004/4/23
#8

Re: XOOPS 2.6 : trouble installation and pre-required ?

If you're getting this message:

Quote:
The openssl extension is missing, which means that secure HTTPS transfers are impossible.

then obviously something there is wrong.

Check the php.ini file from within WAMP, as well as the WAMP extension indicator itself

Resized Image


Sometimes, the php.ini is stored somewhere else than we think. So it's always good to check directly from within WAMP...
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

alain01

Quite a regular
Posted on: 2014/4/12 1:01
alain01
alain01 (Show more)
Quite a regular
Posts: 328
Since: 2003/6/20
#9

Re: XOOPS 2.6 : trouble installation and pre-required ?

sure, i get same,
php_openssl enabled like in this image !

alain01

Quite a regular
Posted on: 2014/4/12 1:03
alain01
alain01 (Show more)
Quite a regular
Posts: 328
Since: 2003/6/20
#10

Re: XOOPS 2.6 : trouble installation and pre-required ?

and in the php.ini :
;;;;;;;;;;;;;;;;;;;;;;
Dynamic Extensions ;
;;;;;;;;;;;;;;;;;;;;;;

; If 
you wish to have an extension loaded automatically, use the following
syntax:
;
;   
extension=modulename.extension
;
; For 
exampleon Windows:
;
;   
extension=msql.dll
;
; ... or 
under UNIX:
;
;   
extension=msql.so
;
; ... or 
with a path:
;
;   
extension=/path/to/extension/msql.so
;
; If 
you only provide the name of the extensionPHP will look for it in its
; default extension directory.
;
Windows Extensions
Note that ODBC support is built inso no dll is needed for it.
Note that many DLL files are located in the extensions/ (PHP 4ext/ (PHP 5)
extension folders as well as the separate PECL DLL download (PHP 5).
Be sure to appropriately set the extension_dir directive.

;
extension=php_bz2.dll
;extension=php_curl.dll
;extension=php_dba.dll
;extension=php_exif.dll
;extension=php_fileinfo.dll
extension
=php_gd2.dll
;extension=php_gettext.dll
;extension=php_gmp.dll
;extension=php_intl.dll
;extension=php_imap.dll
;extension=php_interbase.dll
;extension=php_ldap.dll
extension
=php_mbstring.dll
;extension=php_ming.dll
;extension=php_mssql.dll
extension
=php_mysql.dll
extension
=php_mysqli.dll
;extension=php_oci8.dll      
;extension=php_oci8_11g.dll 
extension
=php_openssl.dll
;extension=php_pdo_firebird.dll
;extension=php_pdo_mssql.dll
extension
=php_pdo_mysql.dll
;extension=php_pdo_oci.dll
;extension=php_pdo_odbc.dll
;extension=php_pdo_pgsql.dll
extension
=php_pdo_sqlite.dll
;extension=php_pgsql.dll
;extension=php_phar.dll
;extension=php_pspell.dll
;extension=php_shmop.dll
;extension=php_snmp.dll
;extension=php_soap.dll
;extension=php_sockets.dll
;extension=php_sqlite.dll
;extension=php_sqlite3.dll
;extension=php_sybase_ct.dll
;extension=php_tidy.dll
;extension=php_xmlrpc.dll
;extension=php_xsl.dll
;extension=php_zip.dll