xoops forums

luciorota

Module Developer
Posted on: 2014/3/16 8:36
luciorota
luciorota (Show more)
Module Developer
Posts: 197
Since: 2007/4/20
#1

Xoops and jQuery

I recently had problems with newest themes because the JQuery hardcoded in Xoops is too old to work with the latest jQuery plugins.
In Xoops we have the outdated jQuery v1.8.3...
I would like update it to v1.11.0, the latest.
What do you think about?
There will be some problems with themes/modules? What themes/modules?

or

we can have it in /extras ... so people could just copy it over and use it, if they need it...

In your opinions?

Mamba

Moderator
Posted on: 2014/3/16 8:49
Mamba
Mamba (Show more)
Moderator
Posts: 10777
Since: 2004/4/23
#2

Re: Xoops and jQuery

Last year I have committed 1.10.0 to SVN for XOOPS 2.5.6, but I've been told that we need to keep 1.8.3 because some older themes and modules depend on older versions of jQuery.

But that was year ago, and a lot of technologies changed in the meantime, so we definitely could at least provide the newest version in the /extras folder.

How is everybody else feeling?
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs