1
Mamba
PHP 5.3.x for XOOPS 2.6.0 (feedback needed)
  • 2012/12/10 2:22

  • Mamba

  • Moderator

  • Posts: 11251

  • Since: 2004/4/23


We are thinking about using PHP 5.3.x as the minimum requirement for XOOPS 2.6.0.

All major hosts are now offering PHP 5.3.x, PHP 5.4 is already in release 5.4.9, and PHP 5.5 Alpha 1 is already released!

So it seems logical to move to PHP 5.3.x, and start taking advantage of some of the features there.

Please let us know about your status, and vote at this poll:

https://xoops.org/modules/umfrage/index.php?poll_id=7

If you feel that you're stuck with PHP 5.2.x, please let us know why....

Please note: there is no rush to XOOPS 2.6.0 for you, if you are stuck with PHP 5.2.x - XOOPS 2.5.5 series works just fine on PHP 5.2.x

Thank you!
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

2
redheadedrod
Re: PHP 5.3.x for XOOPS 2.6.0 (feedback needed)

Should check out if 5.5 still has the older MySQL connector because they were threatening taking it out which would mean if they did Xoops as it is today without any modifications will not work with it.

Hopefully we can have the new database connector up and running well before then. (Working on it this week...)

Rodney
Attending College working towards Bachelors in Software Engineering and Network Security.

3
irmtfan
Re: PHP 5.3.x for XOOPS 2.6.0 (feedback needed)
  • 2012/12/10 3:19

  • irmtfan

  • Module Developer

  • Posts: 3419

  • Since: 2003/12/7


xoops 2.6.0 must use some important advantages of php 5.3 and it is a big step forward.

Also IMO all major hosts already upgraded to 5.3 and remained hosts have to upgrade at most at the end of 2013.

on the other side, xoops 2.6.0 is a major release with a complete rewrite of all 2.5.5 functions. whenever we have the first RC in hands, a huge testing and debugging will be needed and all old modules should be compatible so i think it takes a lot of time to be stabled.

4
Mamba
Re: PHP 5.3.x for XOOPS 2.6.0 (feedback needed)
  • 2012/12/10 3:53

  • Mamba

  • Moderator

  • Posts: 11251

  • Since: 2004/4/23


Quote:
whenever we have the first RC in hands, a huge testing and debugging will be needed and all old modules should be compatible so i think it takes a lot of time to be stabled.

Of course! But we'll be focusing mainly on the module from "Basic Module Pack", making sure that all of them are working on XOOPS 2.6.0.

We'll need a lot of help from the community! And the module developers to update their modules.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

5
Mamba
Re: PHP 5.3.x for XOOPS 2.6.0 (feedback needed)
  • 2013/1/1 14:35

  • Mamba

  • Moderator

  • Posts: 11251

  • Since: 2004/4/23


Just to let you know - 100% of the people who voted, are for having PHP 5.3 as the minimum PHP version required for XOOPS 2.6.0.

So it is now official:

PHP 5.3+ is the minimum PHP version for XOOPS 2.6.0!


Thanks to everybody who voted!
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Login

Username:
Password:

Lost Password? Register now!

Who's Online

66 user(s) are online (36 user(s) are browsing Support Forums)


Members: 0


Guests: 66


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits