xoops forums

Mamba

Moderator
Posted on: 2010/12/11 11:06
Mamba
Mamba (Show more)
Moderator
Posts: 10988
Since: 2004/4/23
#1

PHP 5.3.4 Released!

http://www.php.net/archive/2010.php#id2010-12-10-1

Security Enhancements and Fixes in PHP 5.3.4:

Fixed crash in zip extract method (possible CWE-170).
Paths with NULL in them (foo\0bar.txt) are now considered as invalid (CVE-2006-7243).
Fixed a possible double free in imap extension (Identified by Mateusz Kocielski). (CVE-2010-4150).
Fixed NULL pointer dereference in ZipArchive::getArchiveComment. (CVE-2010-3709).
Fixed possible flaw in open_basedir (CVE-2010-3436).
Fixed MOPS-2010-24, fix string validation. (CVE-2010-2950).
Fixed symbolic resolution support when the target is a DFS share.
Fixed bug #52929 (Segfault in filter_var with FILTER_VALIDATE_EMAIL with large amount of data) (CVE-2010-3710).

Key Bug Fixes in PHP 5.3.4 include:

Added stat support for zip stream.
Added follow_location (enabled by default) option for the http stream support.
Added a 3rd parameter to get_html_translation_table. It now takes a charset hint, like htmlentities et al.
Implemented FR #52348, added new constant ZEND_MULTIBYTE to detect zend multibyte at runtime.
Multiple improvements to the FPM SAPI.
Over 100 other bug fixes.

I've installed 5.3.4 Windows binary (VC9 x86 Thread Safe) on my WampServer version using these instructions, and everything seems to work fine so far with XOOPS 2.5.0.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

algalochkin

Theme Designer
Posted on: 2010/12/11 14:51
algalochkin
algalochkin (Show more)
Theme Designer
Posts: 1323
Since: 2007/9/23
#2

Re: PHP 5.3.4 Released!

Thanks Mamba!

Very necessary information (including the link on PAMPSERVER)

Somebody tested it with X3?

algalochkin

Theme Designer
Posted on: 2010/12/11 16:24
algalochkin
algalochkin (Show more)
Theme Designer
Posts: 1323
Since: 2007/9/23
#3

Re: PHP 5.3.4 Released!

With XOOPS 2.5.0 is work fine!

Very simple and clear instruction "Install PHP 5.3.x on WAMP" is here http://markushedlund.com/dev-tech/install-php-5.3.3-on-wamp

Mamba

Moderator
Posted on: 2010/12/11 18:21
Mamba
Mamba (Show more)
Moderator
Posts: 10988
Since: 2004/4/23
#4

Re: PHP 5.3.4 Released!

Pampserver is better because it offers 64-bit version.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

aquaportail

Just popping in
Posted on: 2010/12/18 8:11
aquaportail
aquaportail (Show more)
Just popping in
Posts: 20
Since: 2007/7/18
#5

Re: PHP 5.3.4 Released!

Hi,
I've some new tests to go, but it seems this php 5.3 version crashes the admin on old Xoops 2.0.1x...

kris_fr

Theme Designer
Posted on: 2010/12/18 15:43
kris_fr
kris_fr (Show more)
Theme Designer
Posts: 1009
Since: 2005/12/31
#6

Re: PHP 5.3.4 Released!

A few days ago I published the updated versions of my uniformserver and miniserv with : apache 2.2.17, mysql 5.1.53 and php 5.3.4
- miniserver --> http://labs.xoofoo.org/modules/news/article.php?storyid=257
- uniformserver --> http://labs.xoofoo.org/modules/news/article.php?storyid=259

-xoops 2.5 and 3.0 on miniserver --> http://labs.xoofoo.org/modules/news/article.php?storyid=258