1
peterbell
Having uploaded (but not yet installed) modules show up in Modules Administration page
  • 2009/2/1 16:01

  • peterbell

  • Just popping in

  • Posts: 10

  • Since: 2009/1/22


Hi!

Anyone know if there is a limitation on the number of modules you can upload and then install on a single installation of Xoops?

I'm running XOOPS 2.3.2b and I've uploaded (and successfully installed) over twenty modules. However, there are a few modules which, despite my attempt to re-upload and re-install, never end up showing up in the "Modules Administration" page on my website. These modules are the following:

* smartfaq
* smartobject
* smartpartner
* smartsection
* wfdownloads
* xoopspoll

I've tried both default and zetagenesis themes, with the same result in both. Also, I tried to use the "debugging" approach before posting this post, but all that ends up doing is obliterating the site so that I have to go back and restore my files and MySQL database from the backups that the hosting company maintains for me for both.

Any assistance you can provide would be greatly appreciated.

Thanks.

Peter Bell

pbell [at] seomarketsolutions.com

2
stefan88
Re: Having uploaded (but not yet installed) modules show up in Modules Administration page
  • 2009/2/1 23:19

  • stefan88

  • Community Support Member

  • Posts: 1085

  • Since: 2004/9/20


Hi,

this usualy happens when you have module not compatible with your XOOPS system. Try uploading (and installing) modules one by one as one uncompatible module can prevent others to show...

If one module does not show after upload, delete it and then go for the next.

..

3
peterbell
Re: Having uploaded (but not yet installed) modules show up in Modules Administration page
  • 2009/2/2 3:09

  • peterbell

  • Just popping in

  • Posts: 10

  • Since: 2009/1/22


Thanks, I'll try that.

Peter

4
anderssk
Re: Having uploaded (but not yet installed) modules show up in Modules Administration page
  • 2009/2/2 9:45

  • anderssk

  • Quite a regular

  • Posts: 335

  • Since: 2006/3/21


Can also be an error in the language files of the module.

Then try uploading the module (that don't shows in admin) again with only english language files.

If no error, upload the language files one by one to the error ocours again - then You know witch language file is containing errors.

5
peterbell
Re: Having uploaded (but not yet installed) modules show up in Modules Administration page
  • 2009/2/2 13:53

  • peterbell

  • Just popping in

  • Posts: 10

  • Since: 2009/1/22


Thanks to both of you for trying to help me. However, after repeatedly doing what both of you have suggested, I still find that with the following six modules, I still have the same problem. While they are modules that sounded cool and ones that, if they had worked properly on 2.3.2b, I would have enjoyed incorporating into the cite, given the tremendous number of modules available, and also the considerable capabillity of the site without these modules included, I've decided to not try to incorporate them at this point.

The only thing that I think may be a problem for the program is to have these be part of the module packages offered up on sourceforge.

For the newbie, the quickest way to get up and going without having to do a lot of exploration, is to download one or more of the module packs and install them.

Given their presence on the sourceforge site and

6
peterbell
Re: Having uploaded (but not yet installed) modules show up in Modules Administration page
  • 2009/2/2 13:59

  • peterbell

  • Just popping in

  • Posts: 10

  • Since: 2009/1/22


sourceforge site, the recommendation on sourceforge that one use the 2.3.2b version of XOOPS and the implicit recommendation that all of the modules in the module packs can be safely used with version 2.3.2b, it may hurt the reputation of this new version unless the offending modules are removed or someone finds a way to fix them to operate easily with version 2.3.2b.

I'd do it myself if I had the skill sets necessary to accomplish the task, but, unfortunately, I'm still in the middle of the learning curve on php and MySQL and wouldn't be able to produce anything useable at this point.

In any event, thanks very much for your trying to help. I really do appreciate it and I'm really astonished at how quickly I was able to receive a response to my request for help.

Thanks again.

Peter Bell

Login

Username:
Password:

Lost Password? Register now!

Who's Online

63 user(s) are online (31 user(s) are browsing Support Forums)


Members: 0


Guests: 63


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits