1
BlueStocking
The XOOPS Project in 2008 - module repository reform

This offering may be meager in as much as we have all these files in our Module Repository, however we, at XOOPS, believe that backup copies of modules we all work with are important. For this reason we put our heads together and came up with a way of providing you with a copy of our backups.

For a quick copy selection for a one on one basis, see the module text list.

/xoops-module_repository/zip/modulelist.txt

Dear XOOPERS,

IF you want a copy of this entire zip library
I have zipped it at:

http://xoops-end-user.com/MR-zip.zip
This file size is 88.3 MB 1/7/2008 12:35am.

The MR being for module repository and the zip meaning zip files.

Done for your convenience ...by BlueStocking
https://xoops.org/modules/repository .. It is time to get involved - XOOPS.ORG

2
trabis
Re: The XOOPS Project in 2008 - module repository reform
  • 2008/1/8 1:32

  • trabis

  • Core Developer

  • Posts: 2269

  • Since: 2006/9/1 1


Downloading
Thanks!

3
BlueStocking
Re: The XOOPS Project in 2008 - module repository reform

Trabis,

Please make corrections on the text file you see that are needed. I can pull modules from the list that should be pulled and add new ones.

Thanks,
for sharing labors in return.

BlueStocking
https://xoops.org/modules/repository .. It is time to get involved - XOOPS.ORG

4
trabis
Re: The XOOPS Project in 2008 - module repository reform
  • 2008/1/8 2:01

  • trabis

  • Core Developer

  • Posts: 2269

  • Since: 2006/9/1 1


But I have helped backuping the modules :)!
CanĀ“t do no more, sorry, developing, time consuming, bed, bye...

5
maxxy
Re: The XOOPS Project in 2008 - module repository reform
  • 2008/1/8 5:18

  • maxxy

  • Quite a regular

  • Posts: 286

  • Since: 2007/6/11


thank you for updating the xoops.org module repository...

i agree that old modules should be deleted...new users are at risk using old modules..

6
irmtfan
Re: The XOOPS Project in 2008 - module repository reform
  • 2008/1/8 12:56

  • irmtfan

  • Module Developer

  • Posts: 3419

  • Since: 2003/12/7


the only problem is this list is not really Up-To-Date and it cause problems like:
for example smartfaq 1.04 is not php5 compatible so users must install smartfaq 1.08

in the repository i try to add just qualified modules from known developers.
i dont know if my decision is accepted by end users or not but i just think noone needs a buggy module so i dont just close my eyes and add ALL modules.

7
Peekay
Re: The XOOPS Project in 2008 - module repository reform
  • 2008/1/8 15:08

  • Peekay

  • XOOPS is my life!

  • Posts: 2335

  • Since: 2004/11/20


Quote:
smartfaq 1.04 is not php5 compatible so users must install smartfaq 1.08

The fact that you can't discover that from searching the module repository is it's biggest failing.

I would love to see a list of PHP 5 compatible modules by searching the repository, but I can't. If it's any consolation, I can't obtain that list on xoops-addons either.

The repository needs different download software where system requirements are searchable, IMHO.
A thread is for life. Not just for Christmas.

8
irmtfan
Re: The XOOPS Project in 2008 - module repository reform
  • 2008/1/8 15:11

  • irmtfan

  • Module Developer

  • Posts: 3419

  • Since: 2003/12/7


No search is needed. even no badge to show if its compatible with php5/mysql5
the time of php4 is over so IMHO all OLD modules that doesnt have php5 compatibility should be deleted from repository ASAP.

9
Peekay
Re: The XOOPS Project in 2008 - module repository reform
  • 2008/1/8 15:43

  • Peekay

  • XOOPS is my life!

  • Posts: 2335

  • Since: 2004/11/20


Quote:

irmtfan wrote:
all OLD modules that doesnt have php5 compatibility should be deleted from repository ASAP.

So XOOPS works with PHP 4 or 5, but users will only be able to download modules that work with PHP 5?.
A thread is for life. Not just for Christmas.

10
joninzar
Re: The XOOPS Project in 2008 - module repository reform
  • 2008/1/8 17:44

  • joninzar

  • Just popping in

  • Posts: 12

  • Since: 2006/11/7


irmtfan (ando others who I don't know ) thank you very much for your work.
A pretty and hard work. Thank's!!

I think that is well to delete a module's version that not works with actual versions. (versions, eg >2.0.15)

And if 1 new version works fine in php4 and in Php5, well, delete old versions, too.

But I have 3 webs in 2 servers, and the two servers works in this moment in php4.
They'll change soon at php5, but "soon" isn't now yet...

So, if a version works only in php5, please, don't delete an old version of that module if works in php4... yet...

Thank's

Login

Who's Online

43 user(s) are online (30 user(s) are browsing Support Forums)


Members: 0


Guests: 43


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Sep 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits