1
cjhixon
DMS Module questions
  • 2007/2/19 1:53

  • cjhixon

  • Just popping in

  • Posts: 9

  • Since: 2007/2/17


I have a fresh install of XOOPS on a new site. I have installed CBB and it appears to be working. I tried installing DMS 1.0 and cannot seem to get it to work. I hear that DMS is up to 1.19 but try as I may, I cannot find a link. When look go to the administration page and click on the DMS module I see a menu that says DMS Configuration with 9 links. Clicking on any of the links brings up a blank page with two short text strings on it:
Quote:
DMS Configuration
Anonymous User:


Any ideas how to get this module functioning? One of the main purposes of this site is to manage the organizations documents.

Thanks,
Carl

2
cjhixon
Re: DMS Module questions
  • 2007/2/21 1:42

  • cjhixon

  • Just popping in

  • Posts: 9

  • Since: 2007/2/17


Okay,I found the link to the latest version. It is now installed and very close to working. I need to sort out a path issue.

Quote:
Error: Unable to move document. Ensure that the repository is available and that the web server is able to access the repository.
SP:/tmp/php0SJHcz
DP:/DMS_Repository/1/1/1/600001.dat


DMS_Repository is in my public_html folder so it should be the root folder as far as Apache is concerned, correct? The path is configured as follows:
Quote:
Document Storage Path: /DMS_Repository


Folder permissions are 777. Which once I get things working, I'd like to know how to secure the folder so that people cannot access the folder without proper permissions. 777 seems a bit loose to me.

Thanks.
Carl

3
cjhixon
Re: DMS Module questions
  • 2007/2/28 1:17

  • cjhixon

  • Just popping in

  • Posts: 9

  • Since: 2007/2/17


Anyone? hello world.

4
JMorris
Re: DMS Module questions
  • 2007/2/28 2:50

  • JMorris

  • XOOPS is my life!

  • Posts: 2722

  • Since: 2004/4/11


cjhixon,

I've removed your duplicate forum post. Please be sure to only click on the Submit button once when posting a topic.

RE: Your DMS issue...

The latest release of DMS I could find is version 1.87. Download Link

I have not used this module in quite some time, so I have no idea what the root of your problem might be, off the top of my head. However, I can offer you some basic pointers that can help you nail down the problem and guide you to a solution.

1. Make sure you read the module developer's documentation and follow any instructions to the letter. Sometimes, the devil is in the little details.

2. Try re-installing the module following the documentation. Often times, I've found that many problems are introduced by getting in a hurry.

3. Don't double-check your configuration... Triple check it!

4. If you cannot get answers to your questions on this site, try contacting the developer. I've found that most developers are quite willing to help users when they run into problems.

Sorry I couldn't directly answer you question, but I hope the above will get you going in the right direction.
Insanity can be defined as "doing the same thing over and over and expecting different results."

Stupidity is not a crime. Therefore, you are free to go.

5
cjhixon
Re: DMS Module questions
  • 2007/3/1 20:27

  • cjhixon

  • Just popping in

  • Posts: 9

  • Since: 2007/2/17


Thanks for the reply and sorry for the duplicate post. I will run through the documentation again. I have uninstalled and reinstalled several times. I have 1.87 installed. From what I have read, my problem is likely with the directory path structure. The module is working in that it can write to the database, ie the module can create categories. It fails every time that it tries to write to a config file *.php or upload a document to a folder.

Regarding this problem, I will make a $20USD donation to anyone's website that can fix this problem for me and/or explain the solution clearly enough that I can fix it myself. I've spent a lot more time than expected on this little issue.

Thanks,
Carl

6
cjhixon
Re: DMS Module questions
  • 2007/3/5 4:48

  • cjhixon

  • Just popping in

  • Posts: 9

  • Since: 2007/2/17


Done. Got it. Thanks.

7
davidhvoss
Re: DMS Module questions
  • 2007/7/25 1:38

  • davidhvoss

  • Just popping in

  • Posts: 5

  • Since: 2007/7/25


What was the fix? I'm getting the same error.

8
Willem-Jan
Re: DMS Module questions
  • 2007/9/18 12:40

  • Willem-Jan

  • Just popping in

  • Posts: 5

  • Since: 2006/2/23


I do have the same problem. What is the solution?

9
Peekay
Re: DMS Module questions
  • 2007/9/18 15:19

  • Peekay

  • XOOPS is my life!

  • Posts: 2335

  • Since: 2004/11/20


Quote:

cjhixon wrote:
Done. Got it. Thanks.

Yes, if you use the forums for troubleshooting please post your solution so others may benefit.

-- Edit --

...although I just realised the solution was found in March and it's now September!
A thread is for life. Not just for Christmas.

10
Willem-Jan
Re: DMS Module questions
  • 2007/9/18 17:21

  • Willem-Jan

  • Just popping in

  • Posts: 5

  • Since: 2006/2/23


You're right, but the version is still the same.
So if you know the answer... PLEASE.

Login

Username:
Password:

Lost Password? Register now!

Who's Online

60 user(s) are online (43 user(s) are browsing Support Forums)


Members: 0


Guests: 60


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Dec 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits