1
jgiddens
Xoops and CBB not executing HTML or BBCode in Signatures, News blocks, etc
  • 2006/9/13 21:19

  • jgiddens

  • Just popping in

  • Posts: 3

  • Since: 2006/9/13


Hello,

I recently installed XOOPS and I am a bit of a newb. Here is the pertinent details:

Website URL:
http://arisenphoenix.com/xoops/htdocs

XOOPS Version:
XOOPS 2.0.15

XOOPS Theme:
WoW

XOOPS Template Set:
default

PHP Version:
4.3.11

MySQL Version:
4.0.27-max-log

Server Software:
Apache

User's Browser:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

The issue I have is that Images are not displaying at all in signatures. I have created my signature and inserted this line:

[IMG]http://www.arisenphoenix.com/roster/addons/siggen/sig.php?name=Yt[/IMG]

Which is supposed to display a nifty mod-generated image that has all my world of warcraft stats.

Instead I get the exact text you see above. I have searched through these forums, so I made sure that show inline images option was turned on in CBB. I was sure this was CBB only until I tried to create a custom block for the main page and got the same effect.

Just to be sure I have replaced the module_textsanitizer.php that was causing the other odd signature issues.

So, where do I go for the next step in my troubleshooting odyssey?

Thanks in advance for any comments or help you can offer.

Jgiddens

PS. What is the correct name for the codes that we insert in text around here like [IMG]. I know it isnt HTML, is it called BBCode? I cant find any sort of documentation on those commands anywhere on the website.

2
CeBepuH
Re: Xoops and CBB not executing HTML or BBCode in Signatures, News blocks, etc
  • 2006/9/14 3:15

  • CeBepuH

  • Not too shy to talk

  • Posts: 128

  • Since: 2002/6/10


1. img tags should not be in caps as in your example.

2. I don't think it would accept an URL that contains a ? symbol or that does not end with gif/jpg extension.
Humans need fantasy to be humans. To be the place where the fallen angel meets the rising ape.

3
jgiddens
Re: Xoops and CBB not executing HTML or BBCode in Signatures, News blocks, etc
  • 2006/9/15 4:35

  • jgiddens

  • Just popping in

  • Posts: 3

  • Since: 2006/9/13


Hmm..

OK. I changed the [IMG] tag to [img] but still no picture. How do I go about posting an image if .gif/.jgp links are disallowed?

This particular image is from a popular addon that many other websites use (SigGen for WOWRoster) and they are able to post images in signatures.

What would you suggest for the HTML equivalent? I will try it as well.

Thanks.

4
CeBepuH
Re: Xoops and CBB not executing HTML or BBCode in Signatures, News blocks, etc
  • 2006/9/15 4:43

  • CeBepuH

  • Not too shy to talk

  • Posts: 128

  • Since: 2002/6/10


Quote:

jgiddens wrote:

How do I go about posting an image if .gif/.jgp links are disallowed?


I never said that! I said that certain restrictions apply. In other words the image you are posting should end on gif/jpg and should not contain a question mark characters.
Humans need fantasy to be humans. To be the place where the fallen angel meets the rising ape.

5
jgiddens
Re: Xoops and CBB not executing HTML or BBCode in Signatures, News blocks, etc
  • 2006/9/16 0:54

  • jgiddens

  • Just popping in

  • Posts: 3

  • Since: 2006/9/13


Ok, sorry about that. I had misread your note.

So, this type of link is used in boards all over the place to display a customized, generated on the fly image. There must be a way to link to it in Xoops.

What would be the equivalent HTML String?

PS. Is there a website that I should go to that talks more about BBCode?

Login

Who's Online

80 user(s) are online (34 user(s) are browsing Support Forums)


Members: 0


Guests: 80


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits