1
jfmoore
mxDirectory error
  • 2005/8/22 2:01

  • jfmoore

  • Quite a regular

  • Posts: 360

  • Since: 2004/6/6 5


I have been installing and testing modules on my XOOPS 2.2 test site, and, in the process, mxDirectory quit working. When I click on the "Yellow Pages" link in the main menu, I get the following error:

"Fatal error: Call to a member function on a non-object in /home/avenue41/public_html/newsite/modules/mxdirectory/language/english/main.php on line 4"

I tried uninstalling, deleting the directory, re-uploading, and re-installing, but the error persists.

I haven't the foggiest idea what caused it and hope someone has an ided how to fix it.

Thanks,
JFM
...

2
zeroram
Re: mxDirectory error
  • 2005/8/22 4:12

  • zeroram

  • Friend of XOOPS

  • Posts: 326

  • Since: 2004/6/30


simple my friend...

Mx Directory was not designed originally to work with the New XOOPS 2.2

you should only install 2.2 compatible modules

3
jfmoore
Re: mxDirectory error
  • 2005/8/22 4:21

  • jfmoore

  • Quite a regular

  • Posts: 360

  • Since: 2004/6/6 5


Thanks. It's kind of puzzeling, though that it was working and then just stopped.

JFM
...

4
zeroram
Re: mxDirectory error
  • 2005/8/22 6:56

  • zeroram

  • Friend of XOOPS

  • Posts: 326

  • Since: 2004/6/30


before installing any module on your 2.2 xoops

do a search on this forum ... there is a list somewhere with all the compatibles modules for 2.2

5
jlm69
Re: mxDirectory error
  • 2005/8/22 10:07

  • jlm69

  • Module Developer

  • Posts: 719

  • Since: 2002/7/19



6
Mithrandir
Re: mxDirectory error

Quote:
"Fatal error: Call to a member function on a non-object in /home/avenue41/public_html/newsite/modules/mxdirectory/language/english/main.php on line 4"

What is on line 4 of modules/mxdirectory/language/english/main.php ?
"When you can flatten entire cities at a whim, a tendency towards quiet reflection and seeing-things-from-the-other-fellow's-point-of-view is seldom necessary."

Cusix Software

7
jfmoore
Re: mxDirectory error
  • 2005/8/22 16:39

  • jfmoore

  • Quite a regular

  • Posts: 360

  • Since: 2004/6/6 5


John,

Quote:

jlm69 wrote:
This link might help you,

http://tinyurl.com/8ptmm (shortened by JFM)

read it all.

John


From the referenced topic:

Quote:

jlm69 wrote:
You must be using XOOPS version 2.2, because it works fine in XOOPS 2.0.13. To fix it you just need to comment out line 4 in your language/main.php file. It must have been an oversight because I can't find the line that uses line 4 anywhere in the code. So line 4 should look like below:

//$mydirname = $xoopsModule->getVar('dirname');

or you could just delete it.


That seems to have done it. At least as far as getting it working. Haven't done much testing, yet, though. Are you using mxDirectory with XOOPS 2.2? If so, what has been your experience?

Also, I'm going to read the thread you referenced again, as I'm not yet sure if any of those other changes apply to me or not.

Thanks again!

Jere
...

8
jfmoore
Re: mxDirectory error
  • 2005/8/23 23:24

  • jfmoore

  • Quite a regular

  • Posts: 360

  • Since: 2004/6/6 5


Okay, it's working, but it's not quite right. I can't seem to get the website to show up for premium listings. I see from the other thread that the premium flag must be set to "1" which is the cheapest premium listing, and, sure enough, the website shows up. It does not, however, show up for premium categories "2" thru "5", or all of the more expensive listings. Got to be a bug, right? How to fix it?

Jere
...

9
jlm69
Re: mxDirectory error
  • 2005/8/24 19:14

  • jlm69

  • Module Developer

  • Posts: 719

  • Since: 2002/7/19


I think you missed the last post in the other thread.

Go to mxdirectory/templates/xdir_link.html go to about line 30 and find this line:

<{if $link.premium =="1"}>

change it to:

<{if $link.premium >="1"}>

Then go to mxdirectory/templates/xdir_listingfull.html about line 41 and make the same change.

Then for your changes to be applied you need to go into the modules administration and update the module.


I hope that helps,

John

10
jfmoore
Re: mxDirectory error
  • 2005/8/26 18:17

  • jfmoore

  • Quite a regular

  • Posts: 360

  • Since: 2004/6/6 5


Quote:

jlm69 wrote:
I think you missed the last post in the other thread.

Go to mxdirectory/templates/xdir_link.html go to about line 30 and find this line:

<{if $link.premium =="1"}>

change it to:

<{if $link.premium >="1"}>

Then go to mxdirectory/templates/xdir_listingfull.html about line 41 and make the same change.

Then for your changes to be applied you need to go into the modules administration and update the module.


So I did, so I did. Actually, I didn't miss it, but it sounds better than saying that I saw it and just forgot to do it.

Thanks,
Jere
...

Login

Who's Online

185 user(s) are online (131 user(s) are browsing Support Forums)


Members: 0


Guests: 185


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits