1
Dhurgan
parse error, expecting `T_STRING'
  • 2004/2/16 14:14

  • Dhurgan

  • Just popping in

  • Posts: 68

  • Since: 2004/2/11



I get the following error after a successfull install...

Parse errorparse errorexpecting `T_STRING' in /export/local/domains/exelsior/kernel/object.php on line 528


I have a freshly installed Solaris 9 system with Apache 2.0.48 MySQL 4.0.17 and PHP 5.0.0b4 :)

Everything worked well so far, but then when properly installed with all databases running and accessible this is the result of going to the homepage.

I have not installed smarty on this system, perhaps it is a requirement although I cant see that stated anywhere in the installation documents.

Will try that since its a class copy that makes the problem.

Any other info from someone else?

/Dhurgan

2
Mithrandir
Re: parse error, expecting `T_STRING'

Can't help with more than saying that SMARTY is included in XOOPS. You don't have to install it separately.

Could you post line 528 of your kernel/object.php?

Also note that there have been multiple problems with PHP5 beta, which afaik have not been resolved. Howevere, those problems were different from your report.

3
Dhurgan
Re: parse error, expecting `T_STRING'
  • 2004/2/16 15:38

  • Dhurgan

  • Just popping in

  • Posts: 68

  • Since: 2004/2/11


Sure can...
522      /**
   523       * create a clone(copy) of the current object
   524       *
   525       * @access public
   526       * @return object clone
   527       */
   
528      function &clone()
   
529      {
   
530          $class get_class($this);
   
531          $clone = new $class();
   
532          foreach ($this->vars as $k => $v) {
   
533              $clone->assignVar($k$v['value']);
   
534          }
   
535          // need this to notify the handler class that this is a newly cr
eated object
   536          $clone
->setNew();
   
537          return $clone;
   
538      }


/Dhurgan

4
Mithrandir
Re: parse error, expecting `T_STRING'

Hmmmm... why does that create a parse error?

I am 80% certain that this has to do with the reference handling in PHP5.

5
Dhurgan
Re: parse error, expecting `T_STRING'
  • 2004/2/16 15:43

  • Dhurgan

  • Just popping in

  • Posts: 68

  • Since: 2004/2/11


Just wanted to add...

There are no errors reported during the install up to that point, and no errors reported by apache, MySQL or anything else on the system, just that one line returned to me via the webinterface...

I can go down to php 4 of course, but since I'm scratchbuilding this site now, i though I go for the latest :)

I might add that it works fine on MySQL 3 apache 1 and php 4 :)

/Dhurgan

6
Dhurgan
Re: parse error, expecting `T_STRING'
  • 2004/2/16 15:45

  • Dhurgan

  • Just popping in

  • Posts: 68

  • Since: 2004/2/11


Quote:

Mithrandir wrote:
Hmmmm... why does that create a parse error?

I am 80% certain that this has to do with the reference handling in PHP5.


could be, it is a beta after all

Guess I'll try compiling PHP 4 on the system then

/Dhurgan

7
Mithrandir
Re: parse error, expecting `T_STRING'

PHP5 is still a beta and XOOPS doesn't officially support it yet. There will be a LOT of changes in PHP5 and until those are fully disclosed, I think it is wise to experiment with only one variable at a time.
That means, either experiment with mysql, apache, XOOPS OR php - not both XOOPS and php

8
Dhurgan
Re: parse error, expecting `T_STRING'
  • 2004/2/16 15:48

  • Dhurgan

  • Just popping in

  • Posts: 68

  • Since: 2004/2/11


Heh!

I will try the same run with PHP 4 latest candidate instead, if that works I'll bug them instead

BTW,

It migth be a good idea to state somewhere in install docs what version DO work and not just the minimum version

Maybe it is stated somewhere even, I just read the INSTALL.html and a few docs onsite.

/Dhurgan

9
Dhurgan
Re: parse error, expecting `T_STRING'
  • 2004/2/16 16:40

  • Dhurgan

  • Just popping in

  • Posts: 68

  • Since: 2004/2/11


Okie!

Works fine with PHP 4.3.5.RC2, no other changes.

Guess its not time for PHP 5 just yet

/Dhurgan

10
Mithrandir
Re: parse error, expecting `T_STRING'

Quote:
Requirements Wiki:
XOOPS System Requirements

Software Requirements
- A web (www) server (Apache, IIS, Roxen, etc)
- PHP 4.1.0 and higher (4.3.1 or higher for IIS)
- MySQL Database 3.23.XX or 4.X.XX

Note: one user has reported a problem with MySQL 3.23.49a-MAX. You will likely have difficulties with this version.

Note: if you have a large number of users (several hundred or more), people have reported problems with PHP 4.1.2 which go away when upgrading to a later version of PHP.

Note: not yet officially tested with PHP 5, but some users have already reported problems. More info when PHP5 is released.

Note: XOOPS works very well with PHP 4.3.4 and mySQL 4.0.15 Standard


But you are right - should show in the "Overview" as well as a correct version number (still says that 2.0.5 is the recommended download)

Login

Username:
Password:

Lost Password? Register now!

Who's Online

69 user(s) are online (46 user(s) are browsing Support Forums)


Members: 1


Guests: 68


heyula,

more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits