1
rabideau
php 4.0.6 and Xoops help
  • 2003/11/28 23:41

  • rabideau

  • Home away from home

  • Posts: 1042

  • Since: 2003/4/25


I have a friend whose brother is an ISP. This ISP is only able to support php 4.0.6.

1. Does anyone know which version of XOOPS ran under php 4.0.6 without problems?

2. Is that old version available anywhere for me to download?

I have my friend's site already built using 2.0.5 of Xoops... unfortunately that site crashes (actually won't load anything beyond the index.php page). If you'd like to check the site out it can be found at: http:///www.squareconstruction.com

Any help or recommendations are appreciated.

2
intel352
Re: php 4.0.6 and Xoops help
  • 2003/11/29 0:40

  • intel352

  • Module Developer

  • Posts: 824

  • Since: 2003/11/23


why does it only support 4.0.6? heck, even Plesk (server administration tool) supports newer versions of PHP than 4.0.6...


have you tried requesting that they upgrade the php version? they might be willing to do that...

3
rabideau
Re: php 4.0.6 and Xoops help
  • 2003/11/29 1:14

  • rabideau

  • Home away from home

  • Posts: 1042

  • Since: 2003/4/25


They say that Sun (their support provider) will only support php v 4.0.6. Their (the support provider's) claim is that newer versions of php are too buggy. A lame excuse, I know. Unfortunately, I still need to find an older version of XOOPS that will work with 4.0.6 for my friend...

4
intel352
Re: php 4.0.6 and Xoops help
  • 2003/11/29 1:30

  • intel352

  • Module Developer

  • Posts: 824

  • Since: 2003/11/23


you're prolly gonna be outta luck with most CMS's, cus from what i've seen, XOOPS v1.xx might possibly work with php4.0.6, but wasn't very good imho(that's why i didn't go with XOOPS when i was originally looking for a CMS), phpnuke has too many security issues and bugs, but once you apply ALL the patches, it might be worth trying to see if it works with php 4.0.6

nsnnuke is a much nicer branch of phpnuke, more security-oriented, better interface, etc, but is still in beta-phase

http://opensourcecms.com/ << look here, demos of tons of different cms's, test them out, find some that you like, and check with the developers of that cms for 4.0.6 support



or you could wait and see if the XOOPS dev have a suggestion for you, cus if you can get a version of xoop2 to run on php4.0.6, that would be the best way to go


5
mvandam
Re: php 4.0.6 and Xoops help
  • 2003/11/29 2:01

  • mvandam

  • Quite a regular

  • Posts: 253

  • Since: 2003/2/7 2


I'm not at all familiar with XOOPS 1.x but that may be a possibility. Some don't like it, some do.

Also check out opensourcecms, I'm sure there are several there which support 4.0.6.

Xoops did support 4.0.6 for a while, even the 2.x series (I think). I'm sure you are not interested in this, but I'm thinking it would be too difficult to convert it so it works... not too difficult, but a **LOT** of work. Basically you'd have to convert any $_GET to $HTTP_GET_VARS, etc. and come up with replacements for a few functions that exist in php 4.1+ but not in 4.0.6.

I can understand not wanting to support certain versions of PHP as some were very buggy. I think the latest release 4.3.4 is supposed to be quite good though... maybe they can reconsider??

Login

Who's Online

228 user(s) are online (140 user(s) are browsing Support Forums)


Members: 0


Guests: 228


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits