21
SMEDrieben
Re: extCal 2.37 Final is released
  • 2013/7/29 19:06

  • SMEDrieben

  • Not too shy to talk

  • Posts: 173

  • Since: 2009/6/17


Dear Mamba,

Thanks for the work !

Quote:

This is what is happening:

the developer who wrote an update to extCal 2.28 set default for event_etablissement to 1, i.e. all old entries have now the new field "event_etablissement" added to them with the value 1. But there is no corresponding location in the table "_extcal_etablissement", so this generates an error.

The best way is to go to phpMyAdmin and change all "old" entries for "event_etablissement" to 0.


This solution works !

Quote:

setlocale(LC_ALL, 'de_DE');


My site is in Dutch, but that is not my point. In /language/nederlands/locale.php this setting was:

setlocale(LC_ALL'nl_NL');


Your solution works if I change to nld_NLD or dutch_DUTCH. At least in Windows.

My ISP is on Linux: there, those solutions don't work.

Solutions for Linux ?

Kinds regards,

SMEDrieben


22
Mamba
Re: extCal 2.37 Final is released
  • 2013/7/29 19:23

  • Mamba

  • Moderator

  • Posts: 11254

  • Since: 2004/4/23


Quote:
Your solution works if I change to nld_NLD or dutch_DUTCH. At least in Windows.

My ISP is on Linux: there, those solutions don't work.

Solutions for Linux ?

The solution for Linux was in the link that I've provided for setlocale, if you look at the first example:

/* Set locale to Dutch */
setlocale(LC_ALL'nl_NL');

It should work.

When you say, it doesn't work, you mean - you're still getting English weekdays?

[EDIT] Try to comment out line 14 in xoops_version.php:

setlocale(LC_TIME$xoopsConfig['language']);

I don't think it should be there, but please test and let me know.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

23
SMEDrieben
Re: extCal 2.37 Final is released
  • 2013/7/29 19:55

  • SMEDrieben

  • Not too shy to talk

  • Posts: 173

  • Since: 2009/6/17


Unfortunately, both solutions (nl_NL, commenting out setlocale in xoops-version.php) don't work: I'am still getting English weekday names. I tried those both alone and combined.

Furthermore, in Windows, the nld_NLD combination has another disadvantage: the decimale separator becomes a comma (,) and not a dot (.) (e.g. in the modules overview page in the admin section). In the php-manual, there is a warning that this can disturb other scripts.

Wouldn't it be better to use the definitions for weekdays in Extcal from /language/yourlanguage/calendar.php ?

Kind regards,

SMEDrieben

24
Mamba
Re: extCal 2.37 Final is released
  • 2013/7/29 20:13

  • Mamba

  • Moderator

  • Posts: 11254

  • Since: 2004/4/23


I'll test some more.

For me it works fine on WAMP for the Month and Week. I have problems with Agenda Week. It seems like there is lack of consistency on how the weekdays are being created/fetched, but I could be wrong.

I have a German copy of XOOPS 2.5.6 so I'll test on it and get back to you.

Thank you very much for testing and for reporting bugs. I very much appreciate it.

Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

25
Mamba
Re: extCal 2.37 Final is released
  • 2013/7/30 12:08

  • Mamba

  • Moderator

  • Posts: 11254

  • Since: 2004/4/23


Quote:
For me it works fine on WAMP for the Month and Week. I have problems with Agenda Week. It seems like there is lack of consistency on how the weekdays are being created/fetched, but I could be wrong.

I have a German copy of XOOPS 2.5.6 so I'll test on it and get back to you.

I did some more tests, and on my WAMP it works perfectly, incl. switching languages with xLanguage module.

the locale settings for me are:

English:
setlocale(LC_ALL'en_US');

German:
setlocale(LC_ALL'de_DE');

One thing that you have to make sure is that you have the correct translation in extCal. For example, in /extcal/language/german/main.php I have:

define('_MD_EXTCAL_DAY_MONDAY',"Montag");
define('_MD_EXTCAL_DAY_TUESDAY',"Dienstag");
define('_MD_EXTCAL_DAY_WEDNESDAY',"Mittwoch");
define('_MD_EXTCAL_DAY_THURSDAY',"Donnerstag");
define('_MD_EXTCAL_DAY_FRIDAY',"Freitag");
define('_MD_EXTCAL_DAY_SATURDAY',"Samstag");
define('_MD_EXTCAL_DAY_SUNDAY',"Sonntag");


The "locale.php" takes care of the the:
view_calendar-month.php

and the above translation takes care of
view_agenda-week.php

I am uploading now to my Linux server to test it over there, but I assume, it will be the same.

[EDIT] I just tested it on my Linux server and everything works exactly the same as here, i.e. no problems with languages.

On both installations I have PHP 5.4.17 and XOOPS 2.5.6

English:
Resized Image

German:
Resized Image
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

26
SMEDrieben
Re: extCal 2.37 week names issue
  • 2013/8/4 11:58

  • SMEDrieben

  • Not too shy to talk

  • Posts: 173

  • Since: 2009/6/17


Dear Mamba,

Thanks for the testing and all the work !

I can reproduce all issues except one.

On my server of my (Dutch) ISP (Linux, php 5.3.25), it doesn't matter howe the setlocale is defined: weekday names are always returned in English. I tried nl_NL, no_NO, de_DE, nld_NLD, dutch_DUTCH): no differnce.

On WAMP, it works as expected.

I will contact my ISP.

Kind regards,

SMEDrieben

27
biomech
Re: extCal Language Settings
  • 2013/8/21 4:19

  • biomech

  • Not too shy to talk

  • Posts: 161

  • Since: 2002/2/25


Hi Mamba,

Thanks for directing me to this thread. It gave me some things to look at, but I still couldn't find the reason why my install (2.5.6, extcal_2.37_Final) was giving me '_CAL_TUESDAY', etc instead of the English values. I ended up hard coding these into several files to solve my problems.

At this point I'm working on the Submit Event screen in the admin control panel. The start and end dates are not displaying correctly, and the pop-up calendar is not getting the date variables, as you can see from the attached image:

Resized Image

Not sure what is causing this...

- b -

28
Mamba
Re: extCal Language Settings
  • 2013/8/21 5:08

  • Mamba

  • Moderator

  • Posts: 11254

  • Since: 2004/4/23


Quote:
I still couldn't find the reason why my install (2.5.6, extcal_2.37_Final) was giving me '_CAL_TUESDAY', etc instead of the English values.

_CAL_TUESDAY is defined in "/language/english/calendar.php" file:

define('_CAL_TUESDAY',"Tuesday");

Maybe you don't have access to it? Or the file is missing?

Quote:
The start and end dates are not displaying correctly, and the pop-up calendar is not getting the date variables, as you can see from the attached image:

It seems like you have very similar problems to those here

Possibly you're using some old translation of XOOPS where the definition for _CAL_FORMAT is missing.

Try to add this line:

define('_CAL_FORMAT',_SHORTDATESTRING);


to "calendar.php" files in all your local languages:

\language\XXX\calendar.php

If there is already a definition like this:

define('_CAL_FORMAT',"Y-m-d");

Just comment it out, and add the one from above.

Let me know if this worked for you.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

29
biomech
Re: extCal 2.37 Final is released
  • 2013/8/21 5:59

  • biomech

  • Not too shy to talk

  • Posts: 161

  • Since: 2002/2/25


Quote:

Quote:

I still couldn't find the reason why my install (2.5.6, extcal_2.37_Final) was giving me '_CAL_TUESDAY', etc instead of the English values.


_CAL_TUESDAY is defined in "/language/english/calendar.php" file:

define('_CAL_TUESDAY',"Tuesday");

Maybe you don't have access to it? Or the file is missing?


The file seems to be there and I seem to have access to it.

Quote:

[quote]
The start and end dates are not displaying correctly, and the pop-up calendar is not getting the date variables, as you can see from the attached image:

It seems like you have very similar problems to those here

Possibly you're using some old translation of XOOPS where the definition for _CAL_FORMAT is missing.

Try to add this line:

define('_CAL_FORMAT',_SHORTDATESTRING);


to "calendar.php" files in all your local languages:

\language\XXX\calendar.php

If there is already a definition like this:

define('_CAL_FORMAT',"Y-m-d");

Just comment it out, and add the one from above.

Let me know if this worked for you.


I did have "define('_CAL_FORMAT',"Y-m-d");" in \language\english\calendar.php. I commented it out and replaced it with "define('_CAL_FORMAT',_SHORTDATESTRING);" as you suggested, but there was no noticeable effect.

Anything else I might check?

- b -

30
Mamba
Re: extCal 2.37 Final is released
  • 2013/8/21 7:27

  • Mamba

  • Moderator

  • Posts: 11254

  • Since: 2004/4/23


Quote:
I did have "define('_CAL_FORMAT',"Y-m-d");" in \language\english\calendar.php.

Are you using it only with English? Or also with Japanese?
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Login

Who's Online

63 user(s) are online (36 user(s) are browsing Support Forums)


Members: 0


Guests: 63


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits