21
Mithrandir
Re: Multisite hack for XOOPS 2.2

Quote:
URI Pattern : (is empty!)

You need to specify something that the system can look for in order to identify the site.

In this case, I would say that you should write music.domain.com as the URI pattern.
"When you can flatten entire cities at a whim, a tendency towards quiet reflection and seeing-things-from-the-other-fellow's-point-of-view is seldom necessary."

Cusix Software

22
draj
Re: Multisite hack for XOOPS 2.2
  • 2005/8/13 6:39

  • draj

  • Quite a regular

  • Posts: 271

  • Since: 2005/6/23


Hallo Jan!

I did that actually in the beginning. After viewing your first version related to 2.0.9, I removed the URI pattern. It did not work.

You are correct. It should be there. I see that it did not work, because the changes done AFTER the installation did not reflect properly.

Now after your message, I realised that it should be there. So I deleted the subsite totally.

Now it works, that means that I am able to typehttp://Musik.Domain.com and the browser gets the page under the music sub-domain. But the problem is still thereafter.

I see that the link to the Homepage generated under the music.domain.com is of the master domain game.domain.com! Why?

Xoops did simply recognised thehttp://Musik.Domain.com in the location but did not generate the necessary links everywhere for thehttp://Musik.Domain.com?

After login, it redirects to the master game domain and does not remain into the music subdomain.

Also next to the site management in the modules, the INDEX area of the administration shows empty!

Any more suggestions?

I am just soooo pleased for the endless support what all of you guys offer.

23
draj
Re: Multisite hack for XOOPS 2.2
  • 2005/8/13 7:29

  • draj

  • Quite a regular

  • Posts: 271

  • Since: 2005/6/23


Hallo Jan!

In the administration, I noticed that the following link does NOT work at all!

.../system/admin.php?fct=preferences&op=showmod&confcat_id=0&mod=7...

After clicking on it, it says that the page shall be redirected to the earlier page and it does that correctly

24
Mithrandir
Re: Multisite hack for XOOPS 2.2

About not recognising the site, I need to ask some clarification questions.
1) Do you get the music.domain.com front page, when you access that domain? (it'll be identical to the main site, so perhaps change the site title of the main site and see if it changes on music.domain.com too - if it does, it is not recognising the subsite)

2) Is the value of your URL set for the subsite stillhttp://music.domain.com?

Regarding preferences - this is caused by a bug in 2.2 and 2.2.1 where modules without preferences are still having configuration categories created during installation. The site admin module doesn't have any preferences.

The index page of the site admin module administration is blank. I haven't figured out what to put there, yet
"When you can flatten entire cities at a whim, a tendency towards quiet reflection and seeing-things-from-the-other-fellow's-point-of-view is seldom necessary."

Cusix Software

25
draj
Re: Multisite hack for XOOPS 2.2
  • 2005/8/13 20:40

  • draj

  • Quite a regular

  • Posts: 271

  • Since: 2005/6/23


Hallo Jan!

Thanks for taking time to help.

Quote:

Mithrandir wrote:
About not recognising the site, I need to ask some clarification questions.
1) Do you get the music.domain.com front page, when you access that domain? (it'll be identical to the main site, so perhaps change the site title of the main site and see if it changes on music.domain.com too - if it does, it is not recognising the subsite)


Earlier due to URI, it did not resolve at all! After it does, it simply gets thehttp://game.domain.com (Master Domain).

I changed the title and the new title gets reflected in to the subsite also, i.e. change of title in thehttp://game.domain.com reflects also in the subsitehttp://music.domain.com!

There are no signs ofhttp://music.domain.com (subsite).

The Link Home in the subsite pagehttp://music.domain.com has the master domain linkhttp://game.domain.com in it!

Hence it does not generate the subsite page.
Quote:

2) Is the value of your URL set for the subsite stillhttp://music.domain.com?

Regarding preferences - this is caused by a bug in 2.2 and 2.2.1 where modules without preferences are still having configuration categories created during installation. The site admin module doesn't have any preferences.

The index page of the site admin module administration is blank. I haven't figured out what to put there, yet


URL of the subsite is correct. It ishttp://music.domain.com in there. I deleted and installed accurately.

The question is, I do not come to the point to configure the modules and klone them at all. The main page of the subsites is not produced at all.

In the index page, it would be helpful to have a listing of the index page of the subsite listed there. If one wants to have News for the mainsite and Forum for the subsite_1 as the Main/Index page or Start page, it would be better. By this, different subsites shall not only differ by themes but also by content.

26
Mithrandir
Re: Multisite hack for XOOPS 2.2

It seems that the music.domain.com domain is not detected correctly by the site handler and therefore it defaults back to the main site.

The detection code is a simple strpos and certainly not perfect, but I have not had any problems with this so far.

Just out of curiousity - do you have "http://music.domain.com" or "music.domain.com" in the URI pattern? If you have http:// try removing it and see if that changes anything.
"When you can flatten entire cities at a whim, a tendency towards quiet reflection and seeing-things-from-the-other-fellow's-point-of-view is seldom necessary."

Cusix Software

27
draj
Re: Multisite hack for XOOPS 2.2
  • 2005/8/14 6:50

  • draj

  • Quite a regular

  • Posts: 271

  • Since: 2005/6/23


Hallo Jan!

I am using in the httpd.conf the following:

Include /etc/apache/conf/###_vhost.conf

Before, is the following correct? But thats what I have understood fron the earlier post in other 2.0.9 Hack of multisite. The Directives for the subsite in the include file are in there as following:

ServerName game.domain.com (Mastersite)
ServerAlias music.domain.com (Subsite)
DocumentRoot /home/www/html/game

Hence, by typing in the location music.domain.com, it will be redirected to game.domain.com, which in the end get the necessary info from mysql, correct? Just to be sure, if I understand right.

In the URI pattern, it cannot have http:// and it is not necessary as the browser understand amd passes on only truncating http:// to the apache. So entering the references of hypertext protocoll nature of a browsercall is not necessary as it being the default. Beleive me, if you type anything else, likeftp://music.domain.com, you do need to inform the multisite as a browser call ftp:// type of refverence in the URI pattern, otherwise not (I beleive, I may be wrong).

Where could be the problem, in MIME types and Apache handler? Further:

LoadModule mime_magic_module /usr/lib/apache/1.3/mod_mime_magic.so
LoadModule mime_module /usr/lib/apache/1.3/mod_mime.so

TypesConfig /etc/mime.types
DefaultType text/plain

<IfModule mod_mime_magic.c>
MIMEMagicFile share/magic
</IfModule>

<IfModule mod_mime.c>
...
#AddHandler send-as-is asis
...

There is nothing in the MIME types that I can see as a problem. It could only be either in the apache directive, admin/mysql or in the code.

Is there a small script available to determine what subdomain the server recognises?

I mean if the browser resolves into a correct subdomain with correct IP address, it should be working. I checked by ping the subsitehttp://music.domain.com and it resolves. Hence apache also works. It could only be something further or thereafter.

The mainfile has:

define('XOOPS_ROOT_PATH', '/home/www/html/game');
define('XOOPS_RESCUE_URL', 'http://game.domain.com'); // (Mastersite)

28
draj
Re: Multisite hack for XOOPS 2.2
  • 2005/8/14 8:10

  • draj

  • Quite a regular

  • Posts: 271

  • Since: 2005/6/23


Hallo Jan!

I was just checking the XOOPS Protector module. Installation went fine everything was OK.

Thereafter I was curious to see the DB tables. I saw that there were _tables. Looking from the pattern, I realised that they were there from the very first installation when´I missed to enter the DB Prefix. They were created and remained. Thereafter I added the prefix and new tables were created. Hence I suggest to have a forced db prefix during creation and without it, it could be problematic.

This could be also done by having the MySQL field as a required field (cannot be empty), provided if the check is of the field data first and not the subroutine codes following thereafter.

So I manually deleted the _tables. Then afterwards, I deinstalled the subsite i.e. hier music.domain.com. Usually after deleting a subsite, it redirects to the mainsite.

It did not!

It was going into an endless loop showing the following error:

Notice [PHP]: Undefined index: enable_badips in file class/xoopssecurity.php line 212
Notice [PHP]: Undefined index: language in file include/common.php line 173
Notice [PHP]: Undefined index: language in file include/common.php line 193
Notice [PHP]: Undefined index: use_ssl in file include/common.php line 204
Notice [PHP]: Undefined index: use_mysession in file include/common.php line 206
Notice [PHP]: Undefined index: debug_mode in file class/database/mysqldatabase.php line 237
Warning [PHP]: in_array(): Wrong datatype for second argument in file class/database/mysqldatabase.php line 237
Notice [PHP]: Undefined index: debug_mode in file class/database/mysqldatabase.php line 237
Warning [PHP]: in_array(): Wrong datatype for second argument in file class/database/mysqldatabase.php line 237
Notice [PHP]: Undefined index: banners in file include/common.php line 256
Notice [PHP]: Undefined index: debug_mode in file include/common.php line 256
Warning [PHP]: in_array(): Wrong datatype for second argument in file include/common.php line 256
Notice [PHP]: Undefined index: theme_fromfile in file class/template.php line 66
Notice [PHP]: Undefined index: gzip_compression in file class/theme.php line 143
Notice [PHP]: Undefined index: sitename in file class/theme.php line 401
Notice [PHP]: Undefined index: slogan in file class/theme.php line 402
Notice [PHP]: Undefined index: debug_mode in file class/database/mysqldatabase.php line 237
Warning [PHP]: in_array(): Wrong datatype for second argument in file class/database/mysqldatabase.php line 237
Notice [PHP]: Undefined index: slogan in file class/theme.php line 420
Notice [PHP]: Undefined index: closesite in file include/common.php line 259
Notice [PHP]: Undefined index: use_mysession in file include/functions.php line 399
Notice [PHP]: Undefined index: theme_set in file class/theme.php line 249
Notice [PHP]: Undefined index: theme_set in file include/functions.php line 450
Notice [PHP]: Undefined index: language in file class/theme.php line 259
Notice [PHP]: Undefined index: theme_set in file include/functions.php line 450
Notice [PHP]: Undefined index: debug_mode in file footer.php line 50
Warning [PHP]: in_array(): Wrong datatype for second argument in file footer.php line 50

I saw that in the database table, there was not a siingle table existing! All the tables were DROPPED due to deleting the subsite!!!

There is a bug in the dropping the subsite. PLease check this part. I had no problems as this was a play subsite anyway. So now I am rebuildung the mainsite and subsite...

29
Mithrandir
Re: Multisite hack for XOOPS 2.2

Quote:
In the URI pattern, it cannot have http:// and it is not necessary as the browser understand amd passes on only truncating http://

The URI pattern has nothing to do with apache or the browser.
The string(s) you specify as URI pattern will be compared with the $_SERVER['REQUEST_URI'] variable and if it matches, that subsite's settings are loaded - or at least it should.

I'm still rather stomped as to why things aren't working for you.
"When you can flatten entire cities at a whim, a tendency towards quiet reflection and seeing-things-from-the-other-fellow's-point-of-view is seldom necessary."

Cusix Software

30
draj
Re: Multisite hack for XOOPS 2.2
  • 2005/8/15 4:36

  • draj

  • Quite a regular

  • Posts: 271

  • Since: 2005/6/23


Hello Jan!

Shall I send you the real URL and server access by PM?

Thanks

Login

Who's Online

242 user(s) are online (149 user(s) are browsing Support Forums)


Members: 0


Guests: 242


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Apr 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits