xoops forums

bjuti

Just can't stay away
Posted on: 2010/4/20 20:10
bjuti
bjuti (Show more)
Just can't stay away
Posts: 871
Since: 2009/1/7 2
#11

Re: RMCommon Utilities 2 and MyWords 2 (Alpha)

MyWords module lacks meta description.

acegamer

Not too shy to talk
Posted on: 2010/4/20 20:46
acegamer
acegamer (Show more)
Not too shy to talk
Posts: 162
Since: 2005/7/11
#12

Re: RMCommon Utilities 2 and MyWords 2 (Alpha)

Quote:

kaotik wrote:
It's very easy to implement the comment system from RMCommon into other modules!
I just did it!
I'll post a tutorial (if it's ok with BitC3R0)


Looking forward to :)

sarahmx

Quite a regular
Posted on: 2010/4/27 10:57
sarahmx
sarahmx (Show more)
Quite a regular
Posts: 378
Since: 2007/10/28
#13

Re: RMCommon Utilities 2 and MyWords 2 (Alpha)

any live site using mywords ? so i can see an example

sarahmx

Quite a regular
Posted on: 2010/4/27 11:51
sarahmx
sarahmx (Show more)
Quite a regular
Posts: 378
Since: 2007/10/28
#14

Re: RMCommon Utilities 2 and MyWords 2 (Alpha)

ok try to install rmcommon and mywords in one of my site

the module page load with no style...white background

Quote:

Call to undefined function load_mod_locale() in /public_html/modules/mywords/xoops_version.php on line 11



pref page modules/system/admin.php?fct=preferences&op=show&confcat_id=1 - Blank


turning on debug ..
i have this error


Quote:

Class 'RMTemplate' not found in /home/xxxxxxxxx/modules/rmcommon/admin_loader.php on line 18


i have reupload all the files..ive checked the adminloader is there

help

kaotik

Just can't stay away
Posted on: 2010/4/27 11:58
kaotik
kaotik (Show more)
Just can't stay away
Posts: 861
Since: 2004/2/19
#15

Re: RMCommon Utilities 2 and MyWords 2 (Alpha)

Hello sarahmx

There's a correct order to get this working:
1- First install rmcommon.
2- upload and set your admin theme to redmexico.
3- Upload and install mywords.

You have to follow this order otherwise it won't work.
There are bugs which I've been reporting and providing solutions at:
http://code.google.com/p/bitcero-modules/issues/list

sarahmx

Quite a regular
Posted on: 2010/4/27 12:42
sarahmx
sarahmx (Show more)
Quite a regular
Posts: 378
Since: 2007/10/28
#16

Re: RMCommon Utilities 2 and MyWords 2 (Alpha)

silly me..i should read the readme.txt

thanks kaotik




sarahmx

Quite a regular
Posted on: 2010/4/28 4:59
sarahmx
sarahmx (Show more)
Quite a regular
Posts: 378
Since: 2007/10/28
#17

Re: RMCommon Utilities 2 and MyWords 2 (Alpha)

Quote:

MyWords module lacks meta description.


in mywords there is a custom field that can be used to add extra metadata to a post that you can use in your theme.

maybe this can be used as meta desc..i tried but is seem not working
------------------------------

mywords is great just some quick issue i spotted

1. layout issue

example in my test site
http://img406.imageshack.us/img406/264/88058097.jpg

maybe this is a theme problem

ignore the erased username and avatar


2. missing author name

"at 12:46 by . " see screenshot above


by the way does rmcommon support comment pagination by default ? or by plugin ...


mywords is full of potential and is a great addition to xoops

will test it further


have also the same bug as reported by kaotik in
http://code.google.com/p/bitcero-modules/issues/list


3. maybe a caption/label for the title text box

http://img517.imageshack.us/img517/6674/87069885.jpg


thank you to kaotik for providing quick fix

vamptrix

Theme Designer
Posted on: 2010/4/28 7:05
vamptrix
vamptrix (Show more)
Theme Designer
Posts: 424
Since: 2008/5/3 1
#18

Re: RMCommon Utilities 2 and MyWords 2 (Alpha)

Sarahmx, I guess that that is a theme problem. Probably, the theme hasn't got classes defined for MyWords (which is kinda logic, as it's a new module).
ke.vinpet.it | Linux, webhosting and networking specialist
Do you need help with hosting, installing or customizing your XOOPS website? I also develop modules and themes for XOOPS.

mjoel

Quite a regular
Posted on: 2010/5/6 4:22
mjoel
mjoel (Show more)
Quite a regular
Posts: 272
Since: 2006/12/9
#19

Re: RMCommon Utilities 2 and MyWords 2 (Alpha)

Have successfully installed rmcommon and mywords

test post in mywords..

and when i try access my account user info modules/profile

i get this fatal error


Fatal error: Class 'MWFunctions' not found in /home/vvvv/public_html/modules/mywords/class/mwpost.class.php on line 303

kaotik

Just can't stay away
Posted on: 2010/5/6 9:39
kaotik
kaotik (Show more)
Just can't stay away
Posts: 861
Since: 2004/2/19
#20

Re: RMCommon Utilities 2 and MyWords 2 (Alpha)

Hi sarahmx
Regarding meta description, you are absolutely right, just missing some line of code. Try this that I provided for bjuti:

https://xoops.org/modules/newbb/viewto ... id=327417#forumpost327417