xoops forums

Catzwolf

Home away from home
Posted on: 2009/3/15 18:04
Catzwolf
Catzwolf (Show more)
Home away from home
Posts: 1392
Since: 2007/9/30
#11

Re: XOOPS 2.3.3 Final Issues

Sure, pm me :)

jdseymour

Friend of XOOPS
Posted on: 2009/3/15 19:31
jdseymour
jdseymour (Show more)
Friend of XOOPS
Posts: 3782
Since: 2004/11/11
#12

Re: XOOPS 2.3.3 Final Issues

Quote:

Catzwolf wrote:
1. I will have a look at the protector issue for you, hopefully the code will through some light on the issue.

2. Just update your AMS module and look to see if the template actually exists in the package.


Yes, all templates exist. I do have a ams_block_spotlight_ams_right.html.php that does not, but not a template file. Do not know what it is doing there, but was created when I updated the module last.

I did update AMS in the module admin, but made no difference.

Catzwolf

Home away from home
Posted on: 2009/3/15 20:02
Catzwolf
Catzwolf (Show more)
Home away from home
Posts: 1392
Since: 2007/9/30
#13

Re: XOOPS 2.3.3 Final Issues

ams_block_spotlight_ams_right.html.php? That sounds like a mistake. XOOPS doesn't create php as templates that's for sure.

jdseymour

Friend of XOOPS
Posted on: 2009/3/15 20:32
jdseymour
jdseymour (Show more)
Friend of XOOPS
Posts: 3782
Since: 2004/11/11
#14

Re: XOOPS 2.3.3 Final Issues

Yes, I agree, but the creation date (or last modified) was Sept 11 2008. ams_block_spotlight_ams_right.html is there. But I believe the problem is with ams_block_spotlight_ams_center,html. it is there, but the warning under errors mention that one, and it is not showing on my home page.

trabis

Core Developer
Posted on: 2009/3/15 20:46
trabis
trabis (Show more)
Core Developer
Posts: 2268
Since: 2006/9/1 1
#15

Re: XOOPS 2.3.3 Final Issues

I'm having problem with formselect.php

Please do not use name=formname[] id=formname[] for multi selectable fields,

Use just
name=formname[] id=formname

using [] in id is causing me problems, thanks.

Catzwolf

Home away from home
Posted on: 2009/3/15 20:46
Catzwolf
Catzwolf (Show more)
Home away from home
Posts: 1392
Since: 2007/9/30
#16

Re: XOOPS 2.3.3 Final Issues

Check in Xoops_version.php to see if that module indeed had that template

Catzwolf

Home away from home
Posted on: 2009/3/15 20:56
Catzwolf
Catzwolf (Show more)
Home away from home
Posts: 1392
Since: 2007/9/30
#17

Re: XOOPS 2.3.3 Final Issues

I am planning on removing all of these from Xoops. I did some work with XOOPS in this area last month and had issues with this myself.

jdseymour

Friend of XOOPS
Posted on: 2009/3/15 20:57
jdseymour
jdseymour (Show more)
Friend of XOOPS
Posts: 3782
Since: 2004/11/11
#18

Re: XOOPS 2.3.3 Final Issues

It does not explicitly list it. Here is the code for the spotlight blocks:

Quote:
$modversion['blocks'][$block_count]['file'] = "ams_spotlight.php";
$modversion['blocks'][$block_count]['name'] = _AMS_MI_NEWS_BNAME12;
$modversion['blocks'][$block_count]['description'] = "Spotlight articles";
$modversion['blocks'][$block_count]['show_func'] = "b_ams_spotlight_show";
$modversion['blocks'][$block_count]['edit_func'] = "b_ams_spotlight_edit";
$modversion['blocks'][$block_count]['options'] = "10|1|".$spotlight_templates_list[0];
$modversion['blocks'][$block_count]['template'] = 'ams_block_spotlight.html';

$block_count++;


Thanks.

Catzwolf

Home away from home
Posted on: 2009/3/15 21:00
Catzwolf
Catzwolf (Show more)
Home away from home
Posts: 1392
Since: 2007/9/30
#19

Re: XOOPS 2.3.3 Final Issues

Nope the template in the modversion array is correct. Not sure why.

I'm trying to help another user at the moment with his site. Once I have done that I will look into your issue properly k.

Catz

trabis

Core Developer
Posted on: 2009/3/15 22:14
trabis
trabis (Show more)
Core Developer
Posts: 2268
Since: 2006/9/1 1
#20

Re: XOOPS 2.3.3 Final Issues

Quote:

trabis wrote:
I'm having problem with formselect.php

Please do not use name=formname[] id=formname[] for multi selectable fields,

Use just
name=formname[] id=formname

using [] in id is causing me problems, thanks.


I guess this is my error, I must have missed some of the upgrades files, this is fixed on 2.3.2b and 2.3.3.

Sorry!