1
waleedpak
Unable to install weblog....
  • 2008/3/1 9:29

  • waleedpak

  • Just popping in

  • Posts: 45

  • Since: 2007/11/25


hello,
whenever i try to intall weblog on my site..
this error returns..

You have an error in your SQL syntaxcheck the manual that corresponds to your MySQL server version for the right syntax to use near 'reads int(100) NOT NULL default '0', trackbacks int(11) NOT NULL default '0', ' at line 10

Unable to install weblog
Error(s):


Please help...
i'm using XOOPS 2.0.16

2
xgarb
Re: Unable to install weblog....
  • 2008/3/1 11:47

  • xgarb

  • Not too shy to talk

  • Posts: 154

  • Since: 2003/3/30


probably the same issues as this..

https://xoops.org/modules/newbb/viewto ... =&topic_id=62386&forum=28

You should upgrade the latest version of XOOPS as well BTW.

3
xgarb
Re: Unable to install weblog....
  • 2008/3/1 17:27

  • xgarb

  • Not too shy to talk

  • Posts: 154

  • Since: 2003/3/30


ok, dunno if this'll work but you could change the line

reads int(100) NOT NULL default '0',

in sql/mysql.sql to

xyzreads int(100) NOT NULL default '0',

When the installer has run change the column title back to reads and the module might work ok. Mine does but it was installed on a a MySQL 4 system first.

Otherwise to do it properly go through all the code and change every reference to reads (as the column in the DB) to a different column name like weblogReads or something.

Then follow the instructions for get_class() in the thread linked above to get it working 100%

4
waleedpak
Re: Unable to install weblog....
  • 2008/3/2 6:53

  • waleedpak

  • Just popping in

  • Posts: 45

  • Since: 2007/11/25


thanks a lot for the help...
now i had installed weblog successfully and changed the xyzreads back to reads...

but now when i try to create a new category
it appears that "category could not be created" on the XOOPS redirection screen...

and when i add "webmaster" to the priveleges section it appears that "database updated successfully" but still "webmaster" was categorized as non-privileged...

please help...

5
hiflyer
Re: Unable to install weblog....
  • 2008/3/6 3:46

  • hiflyer

  • Not too shy to talk

  • Posts: 107

  • Since: 2006/3/7 3


xgarb and waleedpak - thanks for the tip. Changed the reads reference.
I also change all '' to '0' (I assume that's a SQL5 thing? I'm clueless there.)

Installed ok.

Now I keep getting errors in files with the syntax of:

if (strtolower(get_class($entry) != 'weblogentry') { // must be lowercase only

Any PHPers that can help with that one?

Thanks!

6
waleedpak
Re: Unable to install weblog....
  • 2008/3/6 11:37

  • waleedpak

  • Just popping in

  • Posts: 45

  • Since: 2007/11/25


if (strtolower(get_class($entry) != 'weblogentry') { // must be lowercase only


try getting rid of the "(" before strtolower...

maybe that would help

7
globetrotter
Re: Unable to install weblog....

an other great blog modul is Xigg. you can download this great module from here.

regards

8
xgarb
Re: Unable to install weblog....
  • 2008/3/6 17:55

  • xgarb

  • Not too shy to talk

  • Posts: 154

  • Since: 2003/3/30


shouldn't the if statment be..

if (strtolower(get_class($entry)) != 'weblogentry')

? extra bracket after $entry)

9
macmend
Re: Unable to install weblog....
  • 2008/5/23 8:11

  • macmend

  • Quite a regular

  • Posts: 285

  • Since: 2004/2/27


are XOOPS Cube modules like Xigg compatible with XOOPS 2.0.18.1??
Free Mac Support

Ordinary Wisdom

apache server with php sshexec turned on
xoops version 2.0.18.1 & 2.3.1
php version 5.2.5
mysql version 5.0.45

Login

Username:
Password:

Lost Password? Register now!

Who's Online

68 user(s) are online (43 user(s) are browsing Support Forums)


Members: 0


Guests: 68


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits