1
luwie
Pedigree Module /Adding a Dog
  • 2013/5/16 17:18

  • luwie

  • Just popping in

  • Posts: 26

  • Since: 2009/9/6 7


I just installed the new version of Xoops(2.5.6.) and installed the latest Pedigree Module.

First thing we have to look at are the basics.
The basic function of adding a animal and after that connecting the mother and Father are not working anymore.

I added a Dog Called "Amadeus"
I also Added a Dog called "Cooper"
and I added a third Dog called "Gytha"

If I try to connect "Cooper" to "Amadeus" ,I will get the text data saved,but nothing happens.
There is no change in the database

Resized Image


I saw in the administration part under Custom Field the names of the added Dogs show up.
Custom Fields are the fields made by the webmaster
They should be under the "pedigree" part.

This was ok last time I tested.
The part of connecting a dog to it parents did not work in the last version.

If I try to add a Picture ,I will see the following error:
Notice: Undefined variable: xoopsModule in file /modules/pedigree/include/functions.php line 62

So there are many basic things that are not working anymore,this makes it very hard to Test......

testing with:
Minimum PHP required: 5.2 (your version is 5.3.2-1ubuntu4.19)
MYSQL minimum version required: 5.0.7 (your version is 5.1.69-0ubuntu0.10.04.1-log)
Minimum XOOPS required: 2.5.6 (your version is 2.5.6)
Minimum ModuleAdmin required: 1.1 (your version is 1.1)

2
Mamba
Re: Pedigree Module /Adding a Dog
  • 2013/5/16 21:28

  • Mamba

  • Moderator

  • Posts: 11251

  • Since: 2004/4/23


Was it a fresh installation, or did you copy the files over an existing module?

If you copied them over, did you run "update"?

I tested it by adding the parents at the point of adding the new dog. I didn't test it to add parents after the new dog has been added.

I'll look into it.

Could you please provide a "use cases", i.e. what exactly do you do and how, so we can run tests on those processes?

For example, I didn't think about adding parents after adding the dog. Since the parents are older than the new offspring, for the assumption was that they are already in the DB, i.e. they will be selected when we're adding the new dog. So I didn't test on this..

Thanks!
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

3
luwie
Re: Pedigree Module /Adding a Dog
  • 2013/5/17 5:28

  • luwie

  • Just popping in

  • Posts: 26

  • Since: 2009/9/6 7


I made a complete new fresh install of Xoops 2.5.6
I removed the old databases that was there.
So it was a very "clean" install,I think this is a good thing to do with a new version.

After that I added 3 animal`s ,next step is to give 1 animal a fahter and a Mother.
This part is not working anymore.

There are more "bugs" ,but I will make a new topic for each "bug"

If you want see and test :

http://www.lutee.nl/

login: test
Password:test



Hope this helps,Greetings Theo

4
Mamba
Re: Pedigree Module /Adding a Dog
  • 2013/5/17 12:11

  • Mamba

  • Moderator

  • Posts: 11251

  • Since: 2004/4/23


Quote:
There are more "bugs" ,but I will make a new topic for each "bug"

Once you have a list of bugs, you can post all of them here - this will make it easier for me.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

5
luwie
Animal/Pedigree Module Adding a Picture
  • 2013/5/20 16:24

  • luwie

  • Just popping in

  • Posts: 26

  • Since: 2009/9/6 7


When I try to add a Picture ,I will get the following error message:

Notice: Undefined variable: xoopsModule in file /modules/pedigree/include/functions.php line 62

The picture is not shown.


Line 62 in the functions.php:
$img_dir = XOOPS_ROOT_PATH . "/modules/" . $xoopsModule->dirname() . "/images" ;

In de "old" function.php (old version of the pedigree module) it says:

$img_dir = XOOPS_ROOT_PATH . "/modules/animal/images" ;


Greetings Theo

Tested with:
PHP 5.3.2-1ubuntu4.19
MYSQL 5.1.69-0ubuntu0.10.04.1
XOOPS 2.5.6
ModuleAdmin 1.1

6
luwie
Re: Pedigree Module /Adding a Dog
  • 2013/5/20 16:27

  • luwie

  • Just popping in

  • Posts: 26

  • Since: 2009/9/6 7


Quote:

Mamba wrote:
Quote:
There are more "bugs" ,but I will make a new topic for each "bug"

Once you have a list of bugs, you can post all of them here - this will make it easier for me.


Hope this list will help you a little bit:

Adding a Picture:
https://xoops.org/modules/newbb/viewtopic.php?post_id=353720

Latest.php
https://xoops.org/modules/newbb/viewtopic.php?post_id=353722

Custom Fields:
https://xoops.org/modules/newbb/viewtopic.php?post_id=353723

7
luwie
Animal/Pedigree module latest.php
  • 2013/5/20 16:59

  • luwie

  • Just popping in

  • Posts: 26

  • Since: 2009/9/6 7


Step 1 :

Resized Image


Step 2 :

Resized Image


Step 3 :

Resized Image


Step 4:

Resized Image


Step 5 :

Resized Image


Now he will display the latest.php and you will see this:

Resized Image


In the "old" pedigreesoftware it looks like this:

Resized Image


If we use latest.php from the "old" software and copy this file in the new pedigree module then it works OK.

Hope this Helps,Greeting Theo

Tested with:
PHP 5.3.2-1ubuntu4.19
MYSQL 5.1.69-0ubuntu0.10.04.1
XOOPS 2.5.6
ModuleAdmin 1.1

8
luwie
Animal/Pedigree Module Administration Custom Fields
  • 2013/5/20 17:20

  • luwie

  • Just popping in

  • Posts: 26

  • Since: 2009/9/6 7


If we go to the administration part:

And then we goto Custom Fields:

Resized Image


you will see something like this:

Resized Image


Notice that you see no information.

If we now try to edit one off the fields:

Resized Image


You will see this:

Resized Image


This is the data off the dogs entered in the database ,they belong in the PEDIGREE part of the administration.

Hope this Helps ,Greetings Theo

Tested with:
PHP 5.3.2-1ubuntu4.19
MYSQL 5.1.69-0ubuntu0.10.04.1
XOOPS 2.5.6
ModuleAdmin 1.1

9
luwie
Animal/Pedigree Module Editing not working
  • 2013/5/20 17:35

  • luwie

  • Just popping in

  • Posts: 26

  • Since: 2009/9/6 7


We start with an Animal :

Resized Image


If we click "Amadeus",we will go to the page with more information:

Resized Image


The Edit function on the Right side is not working.
Just try changing an Animal from male to female.

Resized Image


The Edit funtion on the left is working OK.

Hope this helps, Greeting Theo

Tested with:
PHP 5.3.2-1ubuntu4.19
MYSQL 5.1.69-0ubuntu0.10.04.1
XOOPS 2.5.6
ModuleAdmin 1.1

10
Mamba
Re: Pedigree Module /Adding a Dog
  • 2013/5/21 11:02

  • Mamba

  • Moderator

  • Posts: 11251

  • Since: 2004/4/23


Thanks for the testing. I'll be looking into these issues this week.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Login

Who's Online

61 user(s) are online (34 user(s) are browsing Support Forums)


Members: 0


Guests: 61


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jul 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits