1
amorinn
XOOPS Physical Path, mainfile.php error
  • 2007/5/18 16:01

  • amorinn

  • Just popping in

  • Posts: 1

  • Since: 2007/5/18


These two fields have automatically populated on both of my installation attempts:
XOOPS Physical Path:
XOOPS Virtual Path (URL):

I assume that the physical path is where the installation is getting hung up based on what happens next:
http://paradigm-raiding.com/xoops1.JPG

If I press next, it says this:
http://paradigm-raiding.com/xoops2.JPG

If I try to go back and start the installation over, it gives me the same error about mainfile.php.

How am I to know what the physical path and virtual path are? It seems that it cannot write to the physical path from the error it gave me, but since that field auto populated, I'm not sure how to know what I should change it to.

Please help

2
martyboy
Re: XOOPS Physical Path, mainfile.php error
  • 2007/5/18 20:04

  • martyboy

  • Quite a regular

  • Posts: 256

  • Since: 2004/5/25


Are you using php5 and maybe an older version of xoops? like 2.0.13.2?

Im not sure if this is exactly your problem but i remember from experiance there is/was an incompatabilty with the installer(from an old XOOPS version) and php5, your prob looks similar to this althoug i could be wrong.

This fix is from rowdie:

in: /install/class/mainfilemanager.php

change
$content fread($filefilesize($this->path) );
fclose($file);


to:
clearstatcache();
$content fread($filefilesize($this->path) );
fclose($file);


link to original forum post
Michael Jackson = King Of Pop

Xoops = King Of CMS

3
zaphmann
Re: XOOPS Physical Path, mainfile.php error
  • 2007/5/22 21:23

  • zaphmann

  • Just popping in

  • Posts: 30

  • Since: 2007/5/22


Trying to install my first XOOPS on my host I get
Could not detect the physical path to your XOOPS directory.
error

It seems similar - so I added the php line suggested and tried again and no luck. My host has suggested several combos for the XOOPS Physical Path field in the administrator but we can't figure out what it wants!!

All the files that were under my htdocs locally are now under a directory called Sites which is the top level of my domain.

We tried entering Sites /Sites / /volumes/xraid01/users/<my domain name>
& /volumes/xraid01/users/<my domain name>/Sites

Nothing works! Have searched halp can't finda solution - PLEASE help!
Thanks
Zaph

4
skenow
Re: XOOPS Physical Path, mainfile.php error
  • 2007/5/22 21:57

  • skenow

  • Home away from home

  • Posts: 993

  • Since: 2004/11/17


Create a new php file using a regular text editor with the following -

<?php print "Physical Directory: ".dirname(__FILE__); ?>


Save it as getdir.php and upload it to the same directory mainfile.php is in. In your browser address bar, type www.yoururl.com/Sites/getdir.php. Your browser should display a page with the physical path for your installation.

5
zaphmann
Re: XOOPS Physical Path, mainfile.php error
  • 2007/5/22 22:14

  • zaphmann

  • Just popping in

  • Posts: 30

  • Since: 2007/5/22


Steve

Unfortunately I was working through mail in reverse!

Brilliant! I will try your suggestion and let you know
Thanks
Zaph

6
zaphmann
Re: XOOPS Physical Path, mainfile.php error
  • 2007/5/22 22:35

  • zaphmann

  • Just popping in

  • Posts: 30

  • Since: 2007/5/22


Hello Steve

I followed your instructions o the letter and initially didn't get a hit - had to remove Sites from the URL request - but then it came back with the info:

Physical Directory: /Volumes/XRAID01/Users/<mydomainname>/Sites

which (apart from capitalisation was the same as one of the earlier options that had been tried.

/volumes/xraid01/users/<mydomainname>/Sites

Anyhow, I cut and paste the physical directory and entered it into the field and got exactly the same error message.

" Could not detect the physical path to your XOOPS directory."

I am wondering, if I continue anyway, as we know this is the directory, will it be OK?

Thanks for the help
Zaph

7
skenow
Re: XOOPS Physical Path, mainfile.php error
  • 2007/5/22 23:53

  • skenow

  • Home away from home

  • Posts: 993

  • Since: 2004/11/17


Quote:

zaphmann wrote:
Hello Steve

I followed your instructions o the letter and initially didn't get a hit - had to remove Sites from the URL request - but then it came back with the info:

Physical Directory: /Volumes/XRAID01/Users/<mydomainname>/Sites

which (apart from capitalisation was the same as one of the earlier options that had been tried.

/volumes/xraid01/users/<mydomainname>/Sites

Anyhow, I cut and paste the physical directory and entered it into the field and got exactly the same error message.

" Could not detect the physical path to your XOOPS directory."

I am wondering, if I continue anyway, as we know this is the directory, will it be OK?

Thanks for the help
Zaph


1. Capitalization is relevant on *nix servers.
2. Since you removed /Sites from the url request and it worked, your host has configured /Sites as your root.
3. Since the installation script is having difficulties with the path detection, I recommend editing mainfile.php yourself (which it looks like you have) and continuing with the install. I would verify the permissions on the folders before continuing though - it may be as simple as that (the apache user does not have read access to the folders)

8
JCDunnart
Re: XOOPS Physical Path, mainfile.php error
  • 2007/5/23 3:28

  • JCDunnart

  • Not too shy to talk

  • Posts: 114

  • Since: 2006/7/1 5


@amorinn

The second screenshot is probably because the file mainfile.php has only been partially written. Upload a new mainfile.php before trying again.

For the problem with writing to the file, I can only suggest you make sure mainfile.php has full read/write/exe permissions while installing...

Login

Who's Online

59 user(s) are online (34 user(s) are browsing Support Forums)


Members: 1


Guests: 58


goffy,

more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits