1
bululin
Fedora 5.0 is there - Is XOOPS compatible
  • 2006/4/13 10:23

  • bululin

  • Friend of XOOPS

  • Posts: 12

  • Since: 2004/6/18


Hi, there
I am new to xoops. I want to install XOOPS on Linux based systems and I knew Fedora core 5.0 just released. Could I use Fedora 5.0 as operating system and install XOOPS as well?

Your opinion is deeply appreciated.

2
JMorris
Re: Fedora 5.0 is there - Is XOOPS compatible
  • 2006/4/13 12:19

  • JMorris

  • XOOPS is my life!

  • Posts: 2722

  • Since: 2004/4/11


As long as FC 5 runs a compatible version of Apache, PHP, and MySQL, there shouldn't be a problem.

XOOPS relys on the three above programs, not the operating system.

Hope that helps.

James

Note: Title edited for clarity.
Insanity can be defined as "doing the same thing over and over and expecting different results."

Stupidity is not a crime. Therefore, you are free to go.

3
bululin
Re: Fedora 5.0 is there - Is XOOPS compatible
  • 2006/4/14 3:00

  • bululin

  • Friend of XOOPS

  • Posts: 12

  • Since: 2004/6/18


Could anyone specify which version of PHP, mySQL, and APache should I use?

Again, your answer is greatly appreciated.

4
gediminasbyt
Re: Fedora 5.0 is there - Is XOOPS compatible

Bululin:

Yes FC5 is released and there is nothing incompatible there with xoops, it has apache2 php5 myslq4 and other things that I had tested almost a year ago on FC4 with testing new releases. Personally I don't like FC5 especially when there are hundreds of things that are broken... There is the end in fedoras especially when redhat decided to take development inhouse...

So the short answer is you will be able to use FC5 with XOOPS as long the modules do not fail completely if used in php5. (I have not used any module that would fail miserabely on php5 only some notifs)

Good luck!

5
JMorris
Re: Fedora 5.0 is there - Is XOOPS compatible
  • 2006/4/14 3:22

  • JMorris

  • XOOPS is my life!

  • Posts: 2722

  • Since: 2004/4/11


In the archive you downloaded, there should have been a docs/ directory with a file called INSTALL.html. This was one of the first things listed in that file.

To install XOOPS for the first time, you'll need to have the minimum following server software pre-installed:

* HTTP Server (Apache or IIS) "Note, XOOPS only officially supports Apache"
* PHP 4.1.0 and higher (4.1.1 or higher recommended)
* MySQL Database 3.23.XX

Side note... You're not locked into using PHP5 on FC5. You can always install PHP 4.x instead.

HTH.

James
Insanity can be defined as "doing the same thing over and over and expecting different results."

Stupidity is not a crime. Therefore, you are free to go.

6
gediminasbyt
Re: Fedora 5.0 is there - Is XOOPS compatible

JMoris:

It might take some experience to install php3 on FC5 which the person is obviously lacking.

I'm not saying it's hard, there is lot's of info, but yum will not provide you with easy update to php3 which is the most stable, with php4 so so stabe and some problems, and php5 that will never see the mainstream in production environment as it includes more bugs and overhead than WinOS

7
smdcom
Re: Fedora 5.0 is there - Is XOOPS compatible

LOL...

I quite agree with JMorris...

In the end if you force uninstall all PHP5 RPM files in FC4, and then you install the FC3 PHP4 RPM’s, it does work.

[root]# rpm -e php-imap php-ldap php-mysql php-pear php

Install any PHP4 RPM you want from Fedora Core 3 Updates. Make sure to install the php and php-pear RPM files together.

I'm using FC5 in my laptop. No more Wind0w5... LOL

Login

Username:
Password:

Lost Password? Register now!

Who's Online

64 user(s) are online (42 user(s) are browsing Support Forums)


Members: 0


Guests: 64


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits