21
Casper_no
Re: "This is your first time to enter the administration section." loop SOLUTION
  • 2005/3/13 5:17

  • Casper_no

  • Just popping in

  • Posts: 1

  • Since: 2005/3/13


Just installed XOOPS for testing.
Think it stops there..
Tested with both IE and Firefox, and got same error with both.
Only way to get it work is if I turn of referer in the FW.
Would like to use Xoops, but if that means all users must turn of referer to use the site the time consumed allready for testing are a waste.
Please, if anybody knows a solution let me know!

22
Speed
Re: "This is your first time to enter the administration section." loop SOLUTION
  • 2005/3/14 8:33

  • Speed

  • Quite a regular

  • Posts: 310

  • Since: 2004/5/18


Ok, now this is affecting my site too.

Any ideas? If backing up database and reinstalling doesn't fix, this is baaaaaaaad news.

Everything worked until this evening when a remote admin got the error. Now it's affecting me too.

Things I've done on the site recently:

1) Updated Protector from x.x.4 to x.x.7 revision from GIJoe's website last night. Seemed to go without a hitch.

2) Updated News from RC2 to release version last night. Seemed to go without a hitch.

3) I had changed access for Registered Users group to have no access to anything at all today. (We had created a new group and this one was not being used any longer so I wanted to cut off any access just in case there were some people missed in the transition).

4) I upgraded to Firefox 1.01 this last week.

5) I ran the Windows disk defragmenter yesterday.

I've tried all the suggestions from this thread to no avail.

Should I panic yet?

23
rowdie
Re: "This is your first time to enter the administration section." loop SOLUTION
  • 2005/3/14 10:39

  • rowdie

  • Just can't stay away

  • Posts: 846

  • Since: 2004/7/21


Quote:

Casper_no wrote:
Only way to get it work is if I turn of referer in the FW.
Would like to use Xoops, but if that means all users must turn of referer to use the site the time consumed allready for testing are a waste.
Please, if anybody knows a solution let me know!


There is a very simple way of stopping the check of referrer, which is outlined in the following FAQ:

How do you disable the check for referrer information

Be aware that turning off the check reduces security of your site. If the majority of your users are blocking sending their referrer information though, it might be worth considering.


Another FAQ about Firewall and HTTP_REFERRER information:

Why am I having problems logging in and posting when my firewall is on?

24
Speed
Re: "This is your first time to enter the administration section." loop SOLUTION
  • 2005/3/14 15:37

  • Speed

  • Quite a regular

  • Posts: 310

  • Since: 2004/5/18


What's really strange about this is that it worked without any problems for nearly a day after my changes. I have to assume that something that I changed caused this state. I've never had issues with firewall, http_referrers, Firefox, etc in the last year.

What changed in XOOPS to bring this fatal error into play?

-----

Some more data: When logging in this morning, it accepted my webmaster name and password and said logging in. I found myself NOT logged in and back at the anonymous user view of the site. I tried twice and then logged in with a test user with normal privileges. That user worked. I logged out and now I can login as webmaster. But I still have the first time admin section loop....

25
Speed
Re: "This is your first time to enter the administration section." loop SOLUTION
  • 2005/3/15 0:15

  • Speed

  • Quite a regular

  • Posts: 310

  • Since: 2004/5/18


Ok, I've got my Admin menu back.

I have an off-site copy of my website that is VERY old on my work machine. I uploaded the adminmenu.php file from the cache directory there to my production server.

Voila!

I'm hoping this will help the XOOPS devs track down what caused this critical failure.

26
DobePhat
Re: "This is your first time to enter the administration section." loop SOLUTION
  • 2005/3/15 16:05

  • DobePhat

  • Friend of XOOPS

  • Posts: 656

  • Since: 2003/4/15


Her is a related problem and solution.

We suddenly had this problem and almost went into a panic.
Suddenly we were asked if this was the first time as admin etc.

Knowing it wasnt, we went to
the direct URL.
http://www.yoursite etc./modules/system/admin.php?fct=preferences

Went to General settings.
Selected YES to update html files from templates went all the way down and clicked GO.

After some stubborness. the necassary files were rebuilt.The site admin menu regenerated itself and now recognized the admin.

(whew) that was scary.

Just a solution for those who may have suddenly and unexpectedly got this error.

27
Speed
Re: "This is your first time to enter the administration section." loop SOLUTION
  • 2005/3/20 4:32

  • Speed

  • Quite a regular

  • Posts: 310

  • Since: 2004/5/18


Ok, I got it to give me this error message again. That's good. If we can find a pattern it can be fixed.

I went into the News 1.3 module and changed the date format. I checked that the formatting looked right on the main page. I tried to re-enter the admin section and was denied access with the "This is your first time..." message.

I restored a copy of the adminmenu.php file into the cache directory from a backup. The admin menu now works again as it is supposed to.

28
UteWebMonkey
Disabling Browser Privacy in Norton Internet Security fixed it for me

I am a brand new user to XOOPS, justs installed it tonight, but had the same admin loop described here until I followed the instructions for disabling Browser Privacy in Norton Internet Security.

I think this is a MAJOR issue that must be fixed immediately. I was planning on migrating my existing community website with over 4000 registered users into this system (and then making a donation of course), but if I'm going to have to be asking people to meddle with their security settings just so they can register and post messages, then that is a showstopper as far as I'm concerned.

It's too bad, too, because this CMS seems to be the most robust, well used and documented of the bunch on Sourceforge.

Just wanted to add my opinion on the severity of this problem.

Thanks.

29
ackbarr
Re: Disabling Browser Privacy in Norton Internet Security fixed it for me

UteWebMonkey - for a workaround, please see the following FAQ:

XOOPS FAQ: How do you disable the check for referrer information?

30
New10x
Re: "This is your first time to enter the administration section." loop
  • 2005/4/15 20:35

  • New10x

  • Just popping in

  • Posts: 24

  • Since: 2005/4/10


I had the same problem Re: "This is your first time to enter the administration section." loop.

I first solved it by turning off Norton Internet Security firewall on my personal computer. Normally, I have it set on "block everything until you approve it." After, turning it off, I could get into my XOOPS administration with no problem using Firefox browser.

I have noticed that I cannot log into this forum or other XOOPS powered forums unless I turn off my firewall. I can't even post to the forums with the firewall on.

With the firewall on, I could get into my XOOPS adminstration section using IE6.

IE6 and Firefox don't allow exactly similar cookie setting and restrictions, even though I've tried to set them similarly. So, mabye it's a cookie thing.

Anyway, turning off the Norton firewall worked. I will note that I'm still running the Windows XP firewall underneath the Norton firewall. With Norton firewall off and Windows firewall on, I have no problem entering any of the XOOPS forums or my own XOOPS administration.

Note: Windows firewall filters and blocks things comming into my computer. Norton firewall filters and blocks things going in both directions. That seems to be the difference with how the firewalls interfer with Xoops.

Login

Username:
Password:

Lost Password? Register now!

Who's Online

57 user(s) are online (28 user(s) are browsing Support Forums)


Members: 0


Guests: 57


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits