1
fluent
resetting permissions
  • 2003/12/2 15:33

  • fluent

  • Just popping in

  • Posts: 43

  • Since: 2003/11/22


In the Admin Menu I now longer have an admin block to configure... just the other blocks... I think this is because I've removed access to it.

I may have but the admin user into a group called webmasters and restricted access that group...

Not to worry...

is there a way I can reset the permissions to save a reinstall of the db?

Jonathan

2
CBlue
Re: resetting permissions

Which version of XOOPS are you using? If it's 2.05 or 2.05.1, then there is a drop down menu at the top of the block admin that lets you pick webmasters to view all the blocks that the webmaster has permission to view.

3
kahumbu
Re: resetting permissions
  • 2003/12/2 16:52

  • kahumbu

  • Documentation Writer

  • Posts: 277

  • Since: 2003/8/23


I'm not sure, but I think he's saying he locked himself out of System Admin by removing access to it through group permissions.

Do a search for "Group Permissions". There's a URL you can use to go to the Group Permissions page.

4
CBlue
Re: resetting permissions

There is no checkbox for accessing system admin in the groups. Only for modules, blocks, avatars, banners, comments, find users, and etc but nothing that would disallow a webmaster from having access to the admin.php file.

5
fluent
Re: resetting permissions
  • 2003/12/4 0:27

  • fluent

  • Just popping in

  • Posts: 43

  • Since: 2003/11/22


I have admin.php and I login as "admin", and there is no system block... just News and FAQ. I dont have access to the main admin block anymore...

6
JackJ
Re: resetting permissions
  • 2003/12/4 0:40

  • JackJ

  • Community Support Member

  • Posts: 747

  • Since: 2003/8/31


log in as admin, and then type this in your browser

http://www.yoursite.com/modules/system/admin.php?fct=groups

Then go to webmasters group and give yourself system admin rights by putting a checkmark in the boxes. This happens by clicking "update" in the webmasters group without checkmarks in the system admin rights.

On initial install you have system admin rights, but the webmasters group defaults to having no checkmarks in the boxes, and when you manually click on "update", your rights are taken away, common occurance..

7
fluent
Re: resetting permissions
  • 2003/12/4 11:41

  • fluent

  • Just popping in

  • Posts: 43

  • Since: 2003/11/22



Thanks, that fixed it!

Jonathan

Login

Who's Online

48 user(s) are online (36 user(s) are browsing Support Forums)


Members: 0


Guests: 48


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Oct 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits