11
trabis
Re: successful login but no rights
  • 2008/5/27 12:49

  • trabis

  • Core Developer

  • Posts: 2269

  • Since: 2006/9/1 1


Quote:

plecavalier wrote:
Hi,

I don't know much about XOOPS and MySQL but I've been asked to fix the following problem:

When you log in with the administrator account XOOPS displays the successfully logged in message and bring me back to the homepage which is normal for this install. However, there is no more link for "Administration Menu" so it seems like the Administrator account no longer has admin rights.

The exact same thing happens when I log in to perform the MUCH needed upgrade to 2.18.1. I login and it brings me right back to the login page with no errors.

Anybody ever see this?


Check you mainfile.php
See if this values are correct:

define( 'XOOPS_GROUP_ADMIN', '1' );
define( 'XOOPS_GROUP_USERS', '2' );
define( 'XOOPS_GROUP_ANONYMOUS', '3' );

12
stomper
Re: successful login but no rights
  • 2008/5/27 13:29

  • stomper

  • Just popping in

  • Posts: 4

  • Since: 2008/5/23


Thanks for your reply.

I've just emptied the xoops_session table but am still having the same problem.

It does appear to be session related though - is there anything else I could do to repair session information?

13
rkennett
Re: successful login but no rights
  • 2008/5/27 15:56

  • rkennett

  • Just popping in

  • Posts: 19

  • Since: 2004/12/17


I installed XOOPS last night and when the install was finished I was logged in with admin rights. I then made this change... index.php to 000index.php so that the folks that would normally visit the site wouldn't see XOOPS naked
Today, after changing the name back to index.php I go through the motions of login but, no access to main or admin menu.

So I wonder how would I manage the Admin user in the admin group without admin access. I must be missing something...perhaps half a brain.

Rick

14
mboyden
Re: successful login but no rights
  • 2008/5/29 16:53

  • mboyden

  • Moderator

  • Posts: 484

  • Since: 2005/3/9 1


Okay, so I did a fresh install of 2.0.18.1 today to a new sandbox (using the tar.gz download). Even though the files had permissions incongruent with my security, I decided I'd try it as is.

I can't replicate the problems you are seeing.

Here's what I did. I created a new database and a new user. I then installed XOOPS. I then logged in and out several times as administrator was able to navigate the system module, make changes, etc.

So, there is something a little screwy going on, but I'm not sure what it is. BTW, did you turn on persistent connections (default is off)?

Can you send the phpinfo output to see what your various pertinent variables are (such as globals, safe_mode, etc.)?

Can you get a fresh install to work? What about a fresh install of an older version?
Pessimists see difficulty in opportunity; Optimists see opportunity in difficulty. --W Churchill

XOOPS: Latest | Debug | Hosting and Web Development

15
rkennett
Re: successful login but no rights
  • 2008/6/1 12:52

  • rkennett

  • Just popping in

  • Posts: 19

  • Since: 2004/12/17


Thank You!
Sorry for the delayed reply. I wish I knew what happened but I can only suspect my ISP did something with CGI or DB permissions for after several hours of disappointment and frustration I went to bed. The next day when I went to show some one the problem it was resolved, it worked. So my disappointment and frustration turned to embarrassment which I handle so much better due to a wealth of experience . Thank you for your effort and offer for support. It is (was) truly appreciated.
Thanks Again
Rick

16
rkennett
Re: successful login but no rights
  • 2008/6/6 11:59

  • rkennett

  • Just popping in

  • Posts: 19

  • Since: 2004/12/17


Yes... same problem. It is not consistent, sometimes I get rights and sometimes I don't. Typically, if I can't get in using Fire Fox, I try I.E. and it works, or the other way around. If I am not getting access via I.E. I will use Fire Fox and I am in.

I have a screen capture, where you see I am logged in, have webmaster rights but no admin menu, in fact XOOPS is looking for a login still.

http://www.holtsvillecivic.org/images/geek.jpg

Hope this helps
Rick

17
River
Re: successful login but no rights
  • 2008/9/15 19:57

  • River

  • Just popping in

  • Posts: 39

  • Since: 2006/2/27


Hi

My version of XOOPS is 2.3 whatever users login, I get "Thank you for loging in..." message,then sent me back to "Un-login" user page. This only happen in Firefox though, I don't have any problems with Opera. So I login via Opera and enable debug mode, and I got this:

SET NAMES 'utf8'
SELECT * FROM xxx_config WHERE (conf_modid = '0' AND conf_catid = '1') ORDER BY conf_order ASC
SELECT sess_data, sess_ip FROM xxx_session WHERE sess_id = '75c128cfe4c439eecc60fd79c0cb00b4'
SELECT * FROM xxx_users WHERE uid=1
DELETE FROM xxx_protector_access WHERE expire < UNIX_TIMESTAMP()
SELECT COUNT(*) FROM xxx_protector_access WHERE ip='xxx.xxx.xxx.xxx' AND request_uri='/main/admin.php'
SELECT COUNT(*) FROM xxx_protector_access WHERE ip='xxx.xxx.xxx.xxx'
INSERT INTO xxx_protector_access SET ip='xxx.xxx.xxx.xxx',request_uri='/main/admin.php',expire=UNIX_TIMESTAMP()+'60'
SELECT * FROM xxx_group_permission WHERE (gperm_name = 'module_admin' AND gperm_modid = '1' AND (gperm_groupid = '1' OR gperm_groupid = '2'))

Can someone help please.

River

18
River
Re: successful login but no rights
  • 2008/9/22 16:52

  • River

  • Just popping in

  • Posts: 39

  • Since: 2006/2/27


I am still having this problem. I can login if I use Opera browser, but when I use firefox, I will get "welcome..." then send back to "before-login" page.

Can someone help?

19
mboyden
Re: successful login but no rights
  • 2008/9/22 18:26

  • mboyden

  • Moderator

  • Posts: 484

  • Since: 2005/3/9 1


Can you turn on debugging and see what error messages you get if any? Look at all of them and see if anything is failing, and where. Do you have any special setup on Firefox, using NoScript, blockers, or other add-ons? Can you install Firefox afresh on another machine without any add-ons and duplicate the exact same behavior?

Let us know....
Pessimists see difficulty in opportunity; Optimists see opportunity in difficulty. --W Churchill

XOOPS: Latest | Debug | Hosting and Web Development

20
rich1785
Re: successful login but no rights
  • 2008/9/23 22:18

  • rich1785

  • Just popping in

  • Posts: 10

  • Since: 2004/1/3 1


I have taken my site and ran a path in the install to show the IP-based URL path to xoops..and did all my development. I converted everything to the domain name, adn all was working well until I started using Firefox, and then the same issue shows up as described here.

I can login, and get the Admin menu block in IE 7 and have no issues. I also can navigate all modules without errors.

When I log off, and use Firefox 3, it will do the login and show the Admin block at the home page correctly, but as soon as you click on any link or module, it throws you out of your permissions and displays the USER LOGIN block. I have custom sessions turned off, and cleared all the sessions table info as well as the Templates_c directory.

I try and login again, and same occurs. Initial login works fine, return you to main page, then when you click on any link it blows out your login and you have no permissions. But if you to a BACK to the previous page, commands and entering into the admin menus are OK..

Any advice?

It also is affecting just registered users as well as admins.

URL: http://www.kingofglorylutheranchurch.org
XOOPS 2.0.15

Login

Who's Online

52 user(s) are online (39 user(s) are browsing Support Forums)


Members: 0


Guests: 52


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Oct 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits