11
smdcom
Re: Multisite hack for XOOPS 2.2

is there any demo site? or anybody success using this hack?

12
Lyrick
Re: Multisite hack for XOOPS 2.2
  • 2005/8/1 17:21

  • Lyrick

  • Just popping in

  • Posts: 33

  • Since: 2005/8/1 1


is it possible for example to install 3 XOOPS versions but administrated in on DB with this hack?

so i have 3 XOOPS portals and everyone the user must be registrated, so people getting tired of this, because they used to be 1 time to this

13
draj
Re: Multisite hack for XOOPS 2.2
  • 2005/8/1 19:30

  • draj

  • Quite a regular

  • Posts: 271

  • Since: 2005/6/23


Hallo!

I shall make it available for you this week. OK.

14
draj
Re: Multisite hack for XOOPS 2.2
  • 2005/8/1 19:36

  • draj

  • Quite a regular

  • Posts: 271

  • Since: 2005/6/23


Hallo!

To have different Portals you do not need three versions.

You need different themes and this should be possible to install with this Module.

You simply need to share the related SET OF tables, like Groups Set, User Set of tables, as mentioned in the other threads.

And then simply use different themes for each site.

The hole idea of this mode is to have one installation for three portals using different themes.

Thats so far as I have understood, but not yet installed.

As mentioned, I shall be iunstalling a demo in a few days for someone and you can have a look then how it works.

15
Lyrick
Re: Multisite hack for XOOPS 2.2
  • 2005/8/2 9:47

  • Lyrick

  • Just popping in

  • Posts: 33

  • Since: 2005/8/1 1


thx, great, sounds good in the mood.
so let´s wait and see

16
fredski
Re: Multisite hack for XOOPS 2.2
  • 2005/8/4 16:01

  • fredski

  • Quite a regular

  • Posts: 265

  • Since: 2004/1/26


sounds like this might be what im looking for too :)

17
Lyrick
Re: Multisite hack for XOOPS 2.2
  • 2005/8/7 21:21

  • Lyrick

  • Just popping in

  • Posts: 33

  • Since: 2005/8/1 1


and how does it look like

18
draj
Re: Multisite hack for XOOPS 2.2
  • 2005/8/7 21:46

  • draj

  • Quite a regular

  • Posts: 271

  • Since: 2005/6/23


HI!

It looks BAD as I am sick. I am sure I wont be able to get things done in the next couple of days as there would be a big pile of work waiting for me.

However, my next step is to play with the demos and show other people here and they are waiting for it too. Hence it has to be done urgently as soon as I can start walking again.

19
smdcom
Re: Multisite hack for XOOPS 2.2

i haven't success installing this multisite hack... anyone have success?

20
draj
Re: Multisite hack for XOOPS 2.2
  • 2005/8/12 12:29

  • draj

  • Quite a regular

  • Posts: 271

  • Since: 2005/6/23


Hallo Jan!

I was trying to install the multisites module and it die not work. It seems that I am making some small mistake somewhere, but before I invest time, I thought of seeking for your help.

1. I get the following PHP Debug error:

Warning [PHP]: strpos(): Empty delimiter. in file modules/site/class/site.php line 193

Dunno, if this is important for you to rectify.

2. I did the following:

a. I installed one subdomain: e.g.http://game.domain.com under the directory game
b. Installed XOOPS 2.2.1 correctly.
c. Uploaded all the files except mainfile.php and installed the module multisite.
d. Created a sub-domainhttp://music.domain.com to point to directory game. The apache is correctly pointing to the directory game.
e. I modified the Rescue URL as specified.
f. I created following directories >> themes, cache, templates_c and uploads making them 777 writable.
g. In the Site Admin, I added as follows:

Site Name : music.domain.com
Site URL :http://music.domain.com
Theme Path : themes
Templates Path templates_c
Upload Path : uploads
Cache Path : cache
URI Pattern : (is empty!)
DB Prefix : music
Shared Tables : Shared tables
----------------
avatar
avatar_user_link
online
priv_msgs
ranks
smiles
users
group_permission
groups
----------------

h. Copied the templates_c and themes directories from /game >> to music. Hence the themes are there available under the second sub-domain.

Thereafter I did not see that the subdomainhttp://music.domain.com pointing to the new site. That means the mainfile.php is not responding or parsing the redirection through the Browser to point tohttp://music.domain.com

Next to Site Management, if I click on Index, it does not show anything but a white area.

Any suggestions? I simply stopped after seeing the debugging error, thinking that it could be the first possibility.

Thanks

Login

Who's Online

241 user(s) are online (153 user(s) are browsing Support Forums)


Members: 0


Guests: 241


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Apr 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits