1
irmtfan
userinfo.php blank page for some users in xoops 2.5.4 and profile module
  • 2012/4/12 6:41

  • irmtfan

  • Module Developer

  • Posts: 3419

  • Since: 2003/12/7


After about 3 years of absence and very low webmaster activation i finally upgrade my main huge website jadoogaran.org (database size is about 1Gig) from 2.2 to 2.5.4
the xoops website information is:

xoops XOOPS 2.5.4
php 5.2.17
mysql 5.0.92-community
safe_mode Off
register_globals Off
magic_quotes_gpc Off
allow_url_fopen On
fsockopen On
post_max_size 8M
max_input_time 60
output_buffering
max_execution_time 30
memory_limit 64M
file_uploads On
upload_max_filesize 100M

The upgrade process goes almost smooth and i could solve some minor issues but i have a really strange problem with the profile module.
firstly i should explain that jadoogaran.org has about 25 custom groups.
after upgrade I informed that some users have blank pages in userinfo.php

http://www.jadoogaran.org/modules/profile/userinfo.php?uid=XXXXX
i should explain that i can not see any error when i activate the debug mode for all users (in xoops_data/configs/xoopsconfig.php 0 - To all users)

i investigate the issue really deep (it takes about 20 hours for me) and finally i found that users belong to one special group have this problem.
that special group id is 20.
IMHO the group id=20 has some conflict with group id=2 (registered users)
when i removed the user from one of the above groups (2 or 20) its problem had been solved.
please reproduce this issue from your end.
i should repeat that i can not see any error when i activate the debug mode for all users. (because i login with that user belong to groups is 2 and 20 and group id 2 and 20 have not any admin permission)

@Mamba and trabis:
i will send you a pm contain the user and password of an example user with blank page.


2
DCrussader
Re: userinfo.php blank page for some users in xoops 2.5.4 and profile module

same config (XOOPS 2.5.5 RC + Wishcraft Profile) - blank page remains. So it's the core, if Wishcraft made a lot of changes to the module....

this bug persist and on clean default installation from 2.3.0
was build-in in some forks, now is solved by forks.

http://xoops.cmsbg.info/modules/profile/userinfo.php?uid=1

ERROR 500 by chrome, possibly bcz some files within core/module ends with LF only instead of CRLF. LF causes infinite line....

Quote:

i should explain that i can not see any error when i activate the debug mode for all users (in xoops_data/configs/xoopsconfig.php 0 - To all users)


Use Chrome 20.0 Beta and u will see
May The Source Be With You!

3
Peekay
Re: userinfo.php blank page for some users in xoops 2.5.4 and profile module
  • 2012/4/12 9:16

  • Peekay

  • XOOPS is my life!

  • Posts: 2335

  • Since: 2004/11/20


Can't you use the profile module developed by the core team that comes with Xoops instead?
A thread is for life. Not just for Christmas.

4
Dante7237
Re: userinfo.php blank page for some users in xoops 2.5.4 and profile module
  • 2012/4/12 12:58

  • Dante7237

  • Friend of XOOPS

  • Posts: 294

  • Since: 2008/5/28


I tend to stick to the "authorized" xoops modules..

Also change these php settings:
allow_url_fopen On
fsockopen On

Or you are pretty much doomed to being owned.
The more I know, the more I know that I really didn't wanna know.

5
Mamba
Re: userinfo.php blank page for some users in xoops 2.5.4 and profile module
  • 2012/4/12 14:04

  • Mamba

  • Moderator

  • Posts: 11373

  • Since: 2004/4/23


So far, I cannot reproduce it. I've tried on two different installations, both with the original Profile module provided by XOOPS.

Fresh installation:
Quote:
XOOPS Version XOOPS 2.5.4
PHP Version 5.3.10
mySQL Version 5.5.20-log
Server API apache2handler
OS WINNT
safe_mode Off
register_globals Off
magic_quotes_gpc Off
allow_url_fopen Off
fsockopen On
post_max_size 8M
max_input_time 60
output_buffering 1
max_execution_time 60
memory_limit 128M
file_uploads On
upload_max_filesize 2M


Updated site from probably XOOPS 2.5.4 or 2.5.3:
Quote:
XOOPS Version XOOPS 2.5.5-RC
PHP Version 5.2.13
mySQL Version 5.0.95-community
Server API cgi
OS Linux
safe_mode Off
register_globals Off
magic_quotes_gpc On
allow_url_fopen Off
fsockopen On
post_max_size 8M
max_input_time 60
output_buffering
max_execution_time 30
memory_limit 32M
file_uploads On
upload_max_filesize 2M


I also tested on this Website here, and it works fine as well (we are using XOOPS 2.5.5 RC)
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

6
DCrussader
Re: userinfo.php blank page for some users in xoops 2.5.4 and profile module

I can give u access to my host, but this isn't helpfull
What about the LF problem reported by banned cms ?
Since affects language files, why not and rest ?
May The Source Be With You!

7
Mamba
Re: userinfo.php blank page for some users in xoops 2.5.4 and profile module
  • 2012/4/13 12:50

  • Mamba

  • Moderator

  • Posts: 11373

  • Since: 2004/4/23


Quote:
What about the LF problem reported by banned cms ?
Since affects language files, why not and test ?

What's the best option to:
a) run a batch test for all files and get a reports what LF standard each file is using
b) run a batch to set the LF for all files to a specific standard?

I can run individual tests in Notepad++, but it would take too much time...
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

8
Peekay
Re: userinfo.php blank page for some users in xoops 2.5.4 and profile module
  • 2012/4/13 14:13

  • Peekay

  • XOOPS is my life!

  • Posts: 2335

  • Since: 2004/11/20


Not sure what issue you are referring to, but as long as you upload PHP files by FTP in ascii/text mode, foreign LF shouldn't be a problem as line feeds are automatically converted to suit the host format, e.g. UNIX/Linux.

Uploading PHP files in binary mode can cause problems.

If you wanted to purify the LF of an entire Xoops install, I guess you could FTP it up... and then down again.
A thread is for life. Not just for Christmas.

9
DCrussader
Re: userinfo.php blank page for some users in xoops 2.5.4 and profile module

Everything will take time, but after it we can put this Mac Apple OS delimiter problem away and to see something else ?

I can contact my HSP and he can make u VBox/VMWare image like shared hosts - with same configuration, environment, same Cent OS version, and u to see why this is coming.

Both profiles gives blank page or above error from chrome 20.0
May The Source Be With You!

10
Mamba
Re: userinfo.php blank page for some users in xoops 2.5.4 and profile module
  • 2012/4/13 18:29

  • Mamba

  • Moderator

  • Posts: 11373

  • Since: 2004/4/23


VBox would be OK - I could test it locally.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Login

Who's Online

541 user(s) are online (312 user(s) are browsing Support Forums)


Members: 0


Guests: 541


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jul 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits