1
Hadesteam
News module keywords do not appear in utf8
  • 2014/8/25 10:59

  • Hadesteam

  • Not too shy to talk

  • Posts: 164

  • Since: 2011/9/5 1


Hi,

I have problem with keywords in news module, when you'll look to the source of my page: http://www.kulturystyka.org.pl/module ... /article.php?storyid=1064

i see this in

<meta name="Keywords" content="je��li,chcesz,mie��,pot����nie,rozwini��t��,sylwetk��,musisz,w,ko��cu,odstawi��,na,bok,program,treningowy,jaki,dotychczas,stosowa��e��,i,wgry����,si��" />

2
brutalicuss
Re: News module keywords do not appear in utf8

This is not utf-8 problem. This is special characters problem. See here and try to fix with Multibyte String

3
Hadesteam
Re: News module keywords do not appear in utf8
  • 2014/8/27 11:23

  • Hadesteam

  • Not too shy to talk

  • Posts: 164

  • Since: 2011/9/5 1


My xoops version is 2.5.7 and in to news module i didnt see strings.php and multibyte.php ...

4
brutalicuss
Re: News module keywords do not appear in utf8

OK, i mean other but OK :)

1st: try set this: <meta charset="UTF-8"> just under your <head> in theme.html in your theme folder
This is for html5 but you just try
(must clear all chache)

if not

Try set this:
<?php
mb_internal_encoding
("UTF-8");
?>

must be at the top in your article.php file in your news folder

if not

find the line
$string preg_replace('/s+?(S+)?$/'''substr($string0$length+1));
around line 650 in file function.php in your news/include folder
and replace with
$string preg_replace('/s+?(S+)?$/'''mb_substr($string0$length+1));



hope it will work :)

5
Hadesteam
Re: News module keywords do not appear in utf8
  • 2014/8/28 10:35

  • Hadesteam

  • Not too shy to talk

  • Posts: 164

  • Since: 2011/9/5 1


none of these proposals did not work. I would like to note that if I type manually metatags when adding the article, then everything is OK. But it's hard to edit more than 1000 articles, which is why I use the option Metagen, which generates 20 words, but does not display properly.

6
brutalicuss
Re: News module keywords do not appear in utf8

OK man, i found a way to fix that, but i dont recommend to use auto keys in future

replace this line:
$content=strtolower($content);

in your news/include/functions.php

with this:
$content=mb_strtolower($content);


this will work :)

7
Hadesteam
Re: News module keywords do not appear in utf8
  • 2014/9/7 10:56

  • Hadesteam

  • Not too shy to talk

  • Posts: 164

  • Since: 2011/9/5 1


Now it works. Thank you very much for your help.

So what do you recommend instead of keywords generated automatically?

8
brutalicuss
Re: News module keywords do not appear in utf8

Hi,
I mean for SEO, not specially in your case - "special characters problem"
You should set your keys custom, relevant to your title and description, the purpose you seek to find your article in internet.
And the keys must be much less, i think 6-7 and less

Аlthough, the keywords are not already especially value for G. in example




Login

Username:
Password:

Lost Password? Register now!

Who's Online

66 user(s) are online (37 user(s) are browsing Support Forums)


Members: 0


Guests: 66


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Dec 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits