1
Mazarin
News 1.67 hangs when submitting articles
  • 2012/6/7 10:32

  • Mazarin

  • Just can't stay away

  • Posts: 533

  • Since: 2008/12/10


I have News 1.67 on a 2.5.5 install and often when submitting articles, the page hangs for a loooong time, eventually resulting in a timeout, but also that multiple instances of the article gets published.

I'm not sure this is specific neither to the latest version of news nor 2.5.5 as I am experiencing similar things in AMS 3.0 (which is based on News) on a 2.4.3 install (both sites are on the same server however).

As you can understand, this is quite annoying, not only because I have to clean it up afterwards, but also because it spams notification e-mails to those who subscribe to those. Anyone experienced something similar?

EDIT: I've noticed that even though the page hangs, the article gets registered in the DB immediately. Could it be the browser trying to send the request several times if it doesn't get any reply from the server?

2
Mamba
Re: News 1.67 hangs when submitting articles
  • 2012/6/7 11:00

  • Mamba

  • Moderator

  • Posts: 11211

  • Since: 2004/4/23


Quote:
EDIT: I've noticed that even though the page hangs, the article gets registered in the DB immediately. Could it be the browser trying to send the request several times if it doesn't get any reply from the server?

The best way would be to try it with a different browser for comparison. Which one are you using right now?
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

3
Mazarin
Re: News 1.67 hangs when submitting articles
  • 2012/6/7 21:34

  • Mazarin

  • Just can't stay away

  • Posts: 533

  • Since: 2008/12/10


Firefox 12. But I've had it with other ones as well. I'll try to replicate the problem with some other ones, but it would be interesting to hear if someone has had some similar experiences.

4
Mazarin
Re: News 1.67 hangs when submitting articles
  • 2012/6/8 8:08

  • Mazarin

  • Just can't stay away

  • Posts: 533

  • Since: 2008/12/10


Same thing with IE. I think multiple submission of articles is just the symptom (and it can be solved by simply closing the browser after submitting the article). The real question is why it "hangs" while submitting (even though it is clearly registered in the db).

5
kerkyra
Re: News 1.67 hangs when submitting articles
  • 2012/6/9 11:01

  • kerkyra

  • Just can't stay away

  • Posts: 553

  • Since: 2005/2/14


the same thing happens with smartsection 2.14, i've been trying to figure it out for some time now. The problem originates server side and not client side. It probably has to do with the cache memory. I tried ob_end_flush after submiting the article and before the redirect. Seems to soften the blow a lil bit but doesnt solve the problem. Perhaps it has something to do with xoops object... :/
www.guidemap.gr - Beta is out...

Login

Username:
Password:

Lost Password? Register now!

Who's Online

64 user(s) are online (41 user(s) are browsing Support Forums)


Members: 0


Guests: 64


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Dec 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits