xoops forums

Anonymous

Posted on: 2012/6/2 23:56
Anonymous
Anonymous (Show more)
Posts: 0
Since:
#1

Publisher (Rev 365 - 31 May 2012) .. looking for testers

Hi,

We are looking for XOOPSers test the latest version of publisher module (Rev 365 - 31 May 2012) :

http://www.sendspace.com/file/gcw77b

Here is the changelog at the moment:
- Updating thumb.php ( 1.19 > 2.8.7 )
- Adding permissions to allow/deny authors to edit/delete their own articles.
- Moving article files list to FILES tab.
- Adding category option for latest files block.
- Adding permissions for categories moderation.
- Adding option to replace file when editing.
- others.

Thanks to Trabis

rgauci

Not too shy to talk
Posted on: 2012/6/3 12:05
rgauci
rgauci (Show more)
Not too shy to talk
Posts: 173
Since: 2007/8/31
#2

Re: Publisher (Rev 365 - 31 May 2012) .. looking for testers

I will for sure as this is one of the great modules ever built for xoops thanks to Trabis and even you!!!!!
Be Set FREE!

Cesagonchu

Moderator
Posted on: 2012/6/3 12:43
Cesagonchu
Cesagonchu (Show more)
Moderator
Posts: 862
Since: 2010/2/1 2
#3

Re: Publisher (Rev 365 - 31 May 2012) .. looking for testers

Thank you I will test

Is it normal that the publisher\language\english\index.html file is empty?

Usually there is this code inside:

<script>history.go(-1);</script>

Dante7237

Friend of XOOPS
Posted on: 2012/6/3 15:27
Dante7237
Dante7237 (Show more)
Friend of XOOPS
Posts: 288
Since: 2008/5/28
#4

Re: Publisher (Rev 365 - 31 May 2012) .. looking for testers

I have it running on my site without any issues so far.
Currently running 2.5.4
I'm getting off my butt today to do the upgrade to 2.5.5 so I'll let you know how that goes..

The more I know, the more I know that I really didn't wanna know.

Cesagonchu

Moderator
Posted on: 2012/6/3 15:56
Cesagonchu
Cesagonchu (Show more)
Moderator
Posts: 862
Since: 2010/2/1 2
#5

Re: Publisher (Rev 365 - 31 May 2012) .. looking for testers

Publisher 1.0 and Xoops 2.5.5

Quote:
Minimum PHP required: 5.2.0 (your version is 5.3.10-1ubuntu3.1)
MYSQL minimum version required: 5.0.7 (your version is 5.5.22-0ubuntu1)
Minimum XOOPS required: 2.5.0 (your version is 2.5.5)
Minimum ModuleAdmin required: 1.1 (your version is 1.1)


1. Add

<script>history.go(-1);</script>


in
publisher\language\english\index.html

otherwise there is a blank page when moving blocks.


2. One error when I create an article (publisher/admin/item.php?op=mod) :

Warningarray_unique() expects parameter 1 to be array, null given in file /modules/publisher/class/permission.php line 149


Dante7237

Friend of XOOPS
Posted on: 2012/6/4 1:27
Dante7237
Dante7237 (Show more)
Friend of XOOPS
Posts: 288
Since: 2008/5/28
#6

Re: Publisher (Rev 365 - 31 May 2012) .. looking for testers

Upgrade to 2.5.5 went without issues, I created new article and published with no errors using Rev 365.

I'll be looking around the user submission stuff and will let you know what I find.
Looking forward to that option working well.

XOOPS Version XOOPS 2.5.5
PHP Version 5.3.13
mySQL Version 5.5.23-55
Server API cgi-fcgi
OS Linux
safe_mode Off
register_globals Off
magic_quotes_gpc Off
allow_url_fopen Off
fsockopen On
post_max_size 64M
max_input_time 60
output_buffering
max_execution_time 30
memory_limit 128M
file_uploads On
upload_max_filesize 64M

The more I know, the more I know that I really didn't wanna know.

davidsless

Just popping in
Posted on: 2012/6/15 1:56
davidsless
davidsless (Show more)
Just popping in
Posts: 49
Since: 2006/10/5
#7

Re: Publisher (Rev 365 - 31 May 2012) .. looking for testers

Hi

Testing on 2.5.5. Install went fine, import from Smartsection, great! Only problem so far. PDF making not working.

I get the following error message
TCPDF error: Missing or incorrect image file: /home/communic/public_html/modules/publisher/tcpdf/cache/jpgp0aO0b

chnwalkman

Just popping in
Posted on: 2012/6/15 3:54
chnwalkman
chnwalkman (Show more)
Just popping in
Posts: 35
Since: 2004/8/25
#8

Re: Publisher (Rev 365 - 31 May 2012) .. looking for testers

System Overview
Quote:
XOOPS Version XOOPS 2.5.5
PHP Version 5.3.5-1ubuntu7.2
mySQL Version 5.1.54-1ubuntu4
Server API apache2handler
OS Linux


1. In the "Recent items (Detail)" block, no "Vist the ..." to display.
edit:
templates/blocks/publisher_items_recent.html
<a href="<{$publisher_url}>"><{$block.lang_visititem}></a>

to:
<a href="<{$publisher_url}>"><{$block.lang_visitItem}></a>

it shows "Visit the Publisher", and when you click this link, it links to XOOPS ROOT, but it should links to the publish module.

2. another question see this.

3. When system environment is:
Quote:
XOOPS Version XOOPS 2.5.5
PHP Version 5.3.5
mySQL Version 5.1.55-community
Server API apache2handler
OS WINNT

I can't creat any article. Click the create button in the input content is not responding.
Quote:
Warning: array_unique() expects parameter 1 to be array, null given in file /modules/publisher/class/permission.php line 149

mrphilong

Quite a regular
Posted on: 2012/6/15 9:09
mrphilong
mrphilong (Show more)
Quite a regular
Posts: 351
Since: 2006/7/14
#9

Re: Publisher (Rev 365 - 31 May 2012) .. looking for testers

When creating new article I got:

Fatal error: Call to a member function read() on a non-object in /modules/publisher/admin/item.php on line 525


Minimum PHP required: 5.2.0 (your version is 5.2.14)
MYSQL minimum version required: 5.0.7 (your version is 5.0.92-log)
Minimum XOOPS required: 2.5.0 (your version is 2.5.5)
Minimum ModuleAdmin required: 1.1 (your version is 1.1)

Shine

Just can't stay away
Posted on: 2012/8/17 15:03
Shine
Shine (Show more)
Just can't stay away
Posts: 822
Since: 2002/7/22
#10

Re: Publisher (Rev 365 - 31 May 2012) .. looking for testers

Are the above mentioned testresult fixed? This is not clear. It looks not if I see date and revis. nr. of this publisher module.

Any news on status of it?