1
playsome
Validation errors caused by mytabs and a fix
  • 2012/1/3 18:48

  • playsome

  • Not too shy to talk

  • Posts: 197

  • Since: 2009/4/15


Hello xoopsers,

Ive been attempting to get my site to validate and I had some strange errors on the validator, let me explain.

On one page I had one error, a missing closing </ul> tag, so i fixed this and it gave me even more errors.

A couple of errors where to do with attributes contruct errors in the mytabs module.

Basically there was no space between rel="" and class="tabs-selected". I believe this threw some other errors such as tag mismatch, etc which i just dont think existed.

Anyway to fix the attributes contruct error with mytabs open up blocks/mytabs_block.php and on line 56 find the line

$selected 'class="tabs-selected"';


And in the value for the variable ad a space at the very start like so

$selected ' class="tabs-selected"';


and this should fix the attributes construct error.


2
Burning
Re: Validation errors caused by mytabs and a fix
  • 2012/1/3 19:13

  • Burning

  • Theme Designer

  • Posts: 1163

  • Since: 2006/8/22


Thanks :) !
Still learning CSS and... english

3
Mamba
Re: Validation errors caused by mytabs and a fix
  • 2012/1/5 17:40

  • Mamba

  • Moderator

  • Posts: 11251

  • Since: 2004/4/23


I've committed it to SVN.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Login

Username:
Password:

Lost Password? Register now!

Who's Online

70 user(s) are online (40 user(s) are browsing Support Forums)


Members: 1


Guests: 69


heyula,

more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits