xoops forums

peterr

Just can't stay away
Posted on: 2010/3/15 0:38
peterr
peterr (Show more)
Just can't stay away
Posts: 518
Since: 2004/8/5 9
#21

Re: WF-Links or any Links Module??

Hi Burning,

Have just downloaded the latest wflinks version 1.08

Thanks very much for the work you have put into this. All files are now included in that download, thanks. :)

Pete

culex

Module Developer
Posted on: 2010/3/20 15:43
culex
culex (Show more)
Module Developer
Posts: 705
Since: 2004/9/23
#22

Re: WF-Links or any Links Module??

Hey nice work with wf links. :)

I have added danish translation to SVN

Only one item noticed. Modinfo line 44 includes 'include/config.php' this file doesnt exist in the zip.

Aparently this contain some defines that may/may not be includede elsewhere in the newer version. I have commented it in my own version and it seem to work just fine anyway

modino.php line 44
//include_once 'include/config.php';

McDonald

Home away from home
Posted on: 2010/3/21 8:19
McDonald
McDonald (Show more)
Home away from home
Posts: 1072
Since: 2005/8/15
#23

Re: WF-Links or any Links Module??

Quote:

culex wrote:
Only one item noticed. Modinfo line 44 includes 'include/config.php' this file doesnt exist in the zip.


Open xoops_version.php and comment out or remove the following line:

include_once 'include/config.php';

weeramon

Just popping in
Posted on: 2010/5/26 19:33
weeramon
weeramon (Show more)
Just popping in
Posts: 42
Since: 2009/12/13
#24

Re: WF-Links or any Links Module??

Hi, just installed wflinks 1.08 on Xoops 2.4.4.

Everything seems to be alright except that if user submits link it does not show up in the admin panel.

(have tried install uninstall and also did on my reinstall configure permissions before I submitted the link on the user side )

still same problem.

Have read some bug messages with dirname

and line 44 config.php

but do not think it is the issue.

Like I said everything went fine no error also the message that it takes 24 hours ......


but the link is not registered.

anyway thanks for the module but would be great if someone could get back with some response and fix.


So Long

ghia

Community Support Member
Posted on: 2010/5/26 20:17
ghia
ghia (Show more)
Community Support Member
Posts: 4954
Since: 2008/7/3 1
#25

Re: WF-Links or any Links Module??

Did you see the following message?
Quote:
Thank-you for your submission.
You will be notified once your request has be approved by the webmaster

Are there no records created in table xoops_wflinks_links?

weeramon

Just popping in
Posted on: 2010/5/26 21:23
weeramon
weeramon (Show more)
Just popping in
Posts: 42
Since: 2009/12/13
#26

Re: WF-Links or any Links Module??

yes I saw this message.

And there is no record in the database !!!

Checked that already.

But thanks for the quick response

weeramon

Just popping in
Posted on: 2010/5/26 21:26
weeramon
weeramon (Show more)
Just popping in
Posts: 42
Since: 2009/12/13
#27

Re: WF-Links or any Links Module??

by the way from the admin side I can add links, there is no problem, it is only from the user side.

zyspec

Module Developer
Posted on: 2010/5/26 22:23
zyspec
zyspec (Show more)
Module Developer
Posts: 1077
Since: 2004/9/21
#28

Re: WF-Links or any Links Module??

weeramon,

Try enabling Xoops Debug and view the SQL data. I suspect that this is because wf-links is trying to set the value of 'lid' to '', which I don't think is allowed in more recent versions of MYSQL on an INSERT since it's an autoincremented field.

It's part of the reason this module needs some 'Move to Blue' mods and to use PHP XoopsObject class structure for database read/writes...

weeramon

Just popping in
Posted on: 2010/5/26 23:00
weeramon
weeramon (Show more)
Just popping in
Posts: 42
Since: 2009/12/13
#29

Re: WF-Links or any Links Module??

Errors:

Notice: Constant _MI_LAWSUIT_ADMENU3 already defined in file /modules/lawsuit/language/english/modinfo.php line 47

Notice: Constant _ESC_MD_AREAS already defined in file /modules/escorts/language/english/modinfo.php line 23

Notice: Constant _ESC_MD_AREAS_DESC already defined in file /modules/escorts/language/english/modinfo.php line 24

Warning: Smarty error: unable to read resource: "default/xo_footerstatic.html" in file /class/smarty/Smarty.class.php line 1093

DEPRECATED

xoops_load('userutility') is deprecated, use xoops_load('xoopsuserutility')

this below for deprecated I believe was even before installing modules
(or at least the wf-links module)

Class 'XoopsTree' is deprecated, check 'XoopsObjectTree' in tree.php
Class 'XoopsTree' is deprecated, check 'XoopsObjectTree' in tree.php


QUERIES

0.000099 - SET NAMES 'utf8'
0.000055 - SET SQL_BIG_SELECTS = 1
0.000098 - SELECT * FROM config WHERE (conf_modid = '0' AND conf_catid = '1') ORDER BY conf_order ASC
0.000685 - SELECT sess_data, sess_ip FROM session WHERE sess_id = '1ea60151f632390b0ba978878eaa864b'
0.000065 - SELECT * FROM users WHERE uid = '1'
0.000058 - SELECT * FROM modules WHERE dirname = 'wflinks'
0.000085 - SELECT * FROM config WHERE (conf_modid = '23') ORDER BY conf_order ASC
0.000055 - SELECT * FROM modules WHERE dirname = 'protector'
0.000141 - DELETE FROM protector_access WHERE expire < UNIX_TIMESTAMP()
0.002080 - SELECT COUNT(*) FROM protector_access WHERE ip='118.173.53.172' AND request_uri='/yellow-pages/modules/wflinks/submit.php'
0.001280 - SELECT COUNT(*) FROM protector_access WHERE ip='118.173.53.172'
0.000192 - INSERT INTO protector_access SET ip='118.173.53.172',request_uri='/yellow-pages/modules/wflinks/submit.php',expire=UNIX_TIMESTAMP()+'60'
0.001608 - SELECT COUNT(*) FROM banner
0.000343 - SELECT * FROM banner LIMIT 1, 1
0.000195 - UPDATE banner SET impmade = impmade+1 WHERE bid = 2
0.000061 - SELECT * FROM config WHERE (conf_modid = '0' AND conf_catid = '3') ORDER BY conf_order ASC
0.000056 - SELECT DISTINCT gperm_itemid FROM group_permission WHERE gperm_name = 'block_read' AND gperm_modid = 1 AND gperm_groupid IN (1,2)
0.000067 - SELECT b.* FROM newblocks b, block_module_link m WHERE m.block_id=b.bid AND b.isactive=1 AND b.visible=1 AND m.module_id IN (0,23) AND b.bid IN (1,2,3,4,5,6,7,8,9,10,62,11,12,61,28,22,23,25,26,27,24,34,35,36,37,38,39,40,41,42,43,44,72,71,70,45,46,47,48,49,50,51,52,53,54,55,56,57,58,59,60,63,66,67,73,74) ORDER BY b.weight, m.block_id
0.000053 - SELECT COUNT(*) FROM priv_msgs WHERE (read_msg = '0' AND to_userid = '1')
0.000061 - SELECT * FROM modules WHERE (hasmain = '1' AND isactive = '1' AND weight > '0') ORDER BY weight ASC, mid ASC
0.000060 - SELECT * FROM group_permission WHERE (gperm_name = 'module_read' AND gperm_modid = '1' AND (gperm_groupid = '1' OR gperm_groupid = '2'))
0.000067 - SELECT * FROM modules WHERE dirname = 'eguide'
0.000063 - SELECT * FROM config WHERE (conf_modid = '11') ORDER BY conf_order ASC
0.000052 - SELECT * FROM eguide_category WHERE catpri=0 ORDER BY weight,catid
0.000054 - SELECT COUNT(*) FROM modules WHERE dirname = 'escorts'
0.000050 - SELECT COUNT(*) FROM `escorts_profile` WHERE uid = '1'
0.000054 - SELECT indeximage, indexheading FROM wflinks_indexpage
0.000068 - SELECT * FROM wflinks_links WHERE lid=0
0.000056 - SELECT * FROM wflinks_cat ORDER BY title
0.000047 - SELECT cid, title FROM wflinks_cat WHERE pid=0 ORDER BY title
0.000055 - SELECT * FROM wflinks_cat WHERE pid=1 ORDER BY title
0.000054 - SELECT * FROM wflinks_cat WHERE pid=2 ORDER BY title




HOPE YOU CAN READ IT



See this at the end of admin control panel:

this of course has nothing to do with wf-links but perhaps you can tell me if I should try to fix it or if it could cause any trouble with the modules functioning.


Notice: Constant _MI_LAWSUIT_ADMENU3 already defined in file /modules/lawsuit/language/english/modinfo.php line 47
Notice: Constant _ESC_MD_AREAS already defined in file /modules/escorts/language/english/modinfo.php line 23
Notice: Constant _ESC_MD_AREAS_DESC already defined in file /modules/escorts/language/english/modinfo.php line 24



Quite a lot to read sorry

ghia

Community Support Member
Posted on: 2010/5/27 0:59
ghia
ghia (Show more)
Community Support Member
Posts: 4954
Since: 2008/7/3 1
#30

Re: WF-Links or any Links Module??

Quote:
I suspect that this is because wf-links is trying to set the value of 'lid' to '', which I don't think is allowed in more recent versions of MYSQL on an INSERT since it's an autoincremented field.
If that is the case, you should try with this in submit.php
$sql "INSERT INTO " $xoopsDB -> prefix'wflinks_links' ) . "    (cid, title, url, submitter, status, date, hits, rating, votes, comments, forumid, published, expired, offline, description, ipaddress, notifypub, country, keywords, item_tag, googlemap, yahoomap, multimap, street1, street2, town, state, zip, tel, fax, voip, mobile, email, vat ) ";
            
$sql .= " VALUES     ($cid, '$title', '$url', '$submitter', '$status', '$date', 0, 0, 0, 0, '$forumid', '$publishdate', 0, '$offline', '$descriptionb', '$ipaddress', '$notifypub', '$country', '$keywords', '$item_tag', '$googlemap', '$yahoomap', '$multimap', '$street1', '$street2', '$town', '$state', '$zip', '$tel', '$fax', '$voip', '$mobile', '$email', '$vat' )";
But as you can add links in admin, this should not help.

Quote:
Notice: Constant _MI_LAWSUIT_ADMENU3 already defined in file /modules/lawsuit/language/english/modinfo.php line 47

Notice: Constant _ESC_MD_AREAS already defined in file /modules/escorts/language/english/modinfo.php line 23

Notice: Constant _ESC_MD_AREAS_DESC already defined in file /modules/escorts/language/english/modinfo.php line 24
These definitions are effectifly twice in the files. Edit them and remove one.

These debug messages, are these from the thank you screen, which lasts only a few seconds, or from the next (module home) screen?
(Click stop in your browser to prevent the load of the next screen.)