1
marckd
migration problem!
  • 2009/12/31 22:02

  • marckd

  • Just popping in

  • Posts: 86

  • Since: 2006/3/16


please

I need help

I have migrated my server, and used the whm import account to do it

but now with the dns propagation already done
I get this

Quote:

Fatal error: Class 'XoopsLogger' not found in /home/zycu/public_html/class/database/databasefactory.php on line 30


I am using an old version, I know, but I hope you can still help me

the connection is working and the database seems to be fine too
as I can connect using other scrtips I have written to the same XOOPS database, but when xoops, from any page I try, I get that :(

I am running out of ideas

please help me

2
sailjapan
Re: migration problem!

Which version of xoops, please?

3
marckd
Re: migration problem!
  • 2010/1/1 1:43

  • marckd

  • Just popping in

  • Posts: 86

  • Since: 2006/3/16


thanks! already fixed

recompiled apache and fixed it

seems something was bad compiled! :)

4
hrac
Re: migration problem!
  • 2010/2/28 11:30

  • hrac

  • Quite a regular

  • Posts: 305

  • Since: 2002/7/15


Hello,

I have same problem. I'm using XAMPP 1.7.3 and XOOPS 2.4.4. When I use on my production I don't have problem, but when I try to use it on test environment on XAMPP I have this problem.

My configuration is:

Windows XP SP3
XOOPS 2.4.4
XAMPP 1.7.3
# Apache 2.2.14 (IPv6 enabled) + OpenSSL 0.9.8l
# MySQL 5.1.41 + PBXT engine
# PHP 5.3.1

Could this happen because of Apache or PHP configuration? Which parameter should I correct. Any idea?

Thanks

5
sailjapan
Re: migration problem!

Error messages, please.

6
hrac
Re: migration problem!
  • 2010/2/28 22:53

  • hrac

  • Quite a regular

  • Posts: 305

  • Since: 2002/7/15


Fatal error: Class 'XoopsLogger' not found in D:\xampp\htdocs\latest\modules\lawsuit\class\elementrenderer.php on line 103

7
Anonymous
Re: migration problem!
  • 2010/5/23 23:37

  • Anonymous

  • Posts: 0

  • Since:


Same fatal error happened with smartfaq.

XOOPS 2.4.5
PHP 5.3.1

8
trabis
Re: migration problem!
  • 2010/5/24 13:03

  • trabis

  • Core Developer

  • Posts: 2269

  • Since: 2006/9/1 1


line 103
$t =& new XoopsFormCheckBox(
has nothing to do with XoopsLogger!!!

I think problem is with php 5.3.1, there must be a bug in that version because code works fine in 5.3.0.

Class XoopsLogger is one of the first classes loaded by Xoops. How can the class disappear???

Now, if you change the line into
$t = new XoopsFormCheckBox(
it should work as expected.

I'm having problems with 5.3.1 in wamp.

Login

Who's Online

74 user(s) are online (49 user(s) are browsing Support Forums)


Members: 0


Guests: 74


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits