1
Rickb
Can not connect to Mysql Db - however I intalled many Xoops
  • 2008/10/19 21:37

  • Rickb

  • Not too shy to talk

  • Posts: 118

  • Since: 2004/10/24


The new servers will not allow me to go pass the data base connection menu. When I intentionally enter the incorrect data I receive the expected, "Ca not connect to the DB" error. However when I enter the correct data, the field get blank, the only field that remains is ServerHost=localhost.

According to the setup. all of the extensions are correct.

Please help,

Rick

2
script_fu
Re: Can not connect to Mysql Db - however I intalled many Xoops

What version are you trying to
install?

apache?
php?
mysql?

3
Rickb
Re: Can not connect to Mysql Db - however I intalled many Xoops
  • 2008/10/19 23:00

  • Rickb

  • Not too shy to talk

  • Posts: 118

  • Since: 2004/10/24


Fixed, the temp folder was incorrectly named.

Thank you so much.

Rick

4
triwaca
Re: Can not connect to Mysql Db - however I intalled many Xoops
  • 2008/11/18 0:38

  • triwaca

  • Just popping in

  • Posts: 11

  • Since: 2007/1/3 2


I am having the exactly same problem!

Xoops 2.3.1 portuguese
Platform Type Debian
PHP Version 4.4.7
MySQL Version 5.0.45

My instalation didn't go trough the step 5/11. Putting the right data, it just reloads the page without the values I entered. If I put wrong values, it shows the error message.

I tried to install XOOPS 2.0.18 in the same host with the same database and everything run just fine.

What exactly temp name is wrong?


5
triwaca
Re: Can not connect to Mysql Db - however I intalled many Xoops
  • 2008/11/18 0:47

  • triwaca

  • Just popping in

  • Posts: 11

  • Since: 2007/1/3 2


Another test: I pick up the same XOOPS package (2.3.1 ptBr) and installed in XAMPP under my XP, and works fine too. So the XOOPS package is OK.

Does this temp folder is related to the server (Apache)?

6
Rickb
Re: Can not connect to Mysql Db - however I intalled many Xoops
  • 2008/11/18 1:18

  • Rickb

  • Not too shy to talk

  • Posts: 118

  • Since: 2004/10/24


You may need to give write permissions, the session will not write. Please check on the PHP ini file.

Rick

7
triwaca
Re: Can not connect to Mysql Db - however I intalled many Xoops
  • 2008/11/18 2:32

  • triwaca

  • Just popping in

  • Posts: 11

  • Since: 2007/1/3 2


I'm sorry, but again you are not clear wich folder should have permissions changed.

About the PHP ini, I don't have access to it, as i'm installing on a internet host (dot5hosting.com).

8
Rickb
Re: Can not connect to Mysql Db - however I intalled many Xoops
  • 2008/11/18 3:01

  • Rickb

  • Not too shy to talk

  • Posts: 118

  • Since: 2004/10/24


Lets try tomorrow morning, Pacific time. I can better help you. If you are unable to get pass saving the database settings then it is a good change it is not a XOOPS issue. You may want to ask your web tech that you are unable to save your config file with php and that there may be a possible ini file that needs write access.

Rick

9
ghia
Re: Can not connect to Mysql Db - however I intalled many Xoops
  • 2008/11/18 10:13

  • ghia

  • Community Support Member

  • Posts: 4953

  • Since: 2008/7/3 1


Some hosters forbid to create datbases programmaticaly. You must do it by hand with your web site admin panel eg. in cPanel with the MySQL database Wizard.
It can also be that there are only a limited number of databases possible. If you are on your maximum, you have to incorporate the XOOPS tables in an existing database. Due to the xoops_prefix system, there are no problems to be expected.
Creating a database is a four step process:
Create a database.
Create a database user.
Assign the user to the database.
Give the user privileges.

10
triwaca
Re: Can not connect to Mysql Db - however I intalled many Xoops
  • 2008/11/18 11:46

  • triwaca

  • Just popping in

  • Posts: 11

  • Since: 2007/1/3 2


No, the problem isn't the database limit, cause I have an unlimited plan. And I just create the database before the instalation, with all privileges. I know it's ok because I just installed XOOPS 2.0.18 in the same database!

For those who want to see (I create a database just for tests):

http://www.cacimba.com.br/install

Database testxoops
Database User xoopsuser
Password 12345
Database is on calango.dot5hostingmysql.com

If you put wrong values, it will show the error message.

If you put the right values, it just reloads the page without the entered values.

Login

Username:
Password:

Lost Password? Register now!

Who's Online

68 user(s) are online (42 user(s) are browsing Support Forums)


Members: 0


Guests: 68


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Dec 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits