1
go2eu
how to solve :Too many connections in file class/database/mysqldatabase.php line 74 ?
  • 2006/9/7 14:58

  • go2eu

  • Just popping in

  • Posts: 16

  • Since: 2004/2/14


Hi,

From time to time I see following error when I open one page of my site :

Suse linux 8.1
PHP 4
Apache 1.3
MySql


Warning [PHP]: Too many connections in file class/database/mysqldatabase.php line 74
Warning [PHP]: MySQL Connection Failed: Too many connections in file class/database/mysqldatabase.php line 74
Error [Xoops]: Unable to connect to database in file class/database/databasefactory.php line 34


Can anyone help with me for a solusion ?

Thank you !


bryan

2
McNaz
Re: how to solve :Too many connections in file class/database/mysqldatabase.php line 74 ?
  • 2006/9/7 15:24

  • McNaz

  • Just can't stay away

  • Posts: 574

  • Since: 2003/4/21


Hi Bryan.

Do you have persistent connections to mySQL?

mainfile.php
define('XOOPS_DB_PCONNECT'1);


If so then set this to 0.

If it is not the above then you will need increase the number of simultaneous connections to your mySQL server.

HTH.

3
go2eu
Re: how to solve :Too many connections in file class/database/mysqldatabase.php line 74 ?
  • 2006/10/11 18:10

  • go2eu

  • Just popping in

  • Posts: 16

  • Since: 2004/2/14


Quote:

McNaz wrote:
Hi Bryan.

Do you have persistent connections to mySQL?

mainfile.php
define('XOOPS_DB_PCONNECT'1);


If so then set this to 0.

If it is not the above then you will need increase the number of simultaneous connections to your mySQL server.

HTH.


thanks alot for your answer!

I checked the 'XOOPS_DB_PCONNECT' was set to 1 .

could you tell me how to increase the number of simultaneous connections to my mySQL server ?

I am running a Suse linux system .

4
macsite2006
Re: how to solve :Too many connections in file class/database/mysqldatabase.php line 74 ?

Hallo can anyone tell me how to increase in MySql?

My website shows :

This page cannot be displayed due to an internal error.

Error [Xoops]: Unable to connect to database in file class/database/databasefactory.php line 34


I have set this to zero (0) as well as one (1)

define('XOOPS_DB_PCONNECT', 1);


both doesnt work. I guess

Quote:
If it is not the above then you will need increase the number of simultaneous connections to your mySQL server.


I need to increase the number but doesnt know how to do. Please help me out xoopslite.

Thanks lots.


I am using:

Xoops v 1.0 ( Cos i dont know how to update to 2.0 and doesnt want to lost data)

Server - apache 1.3
System - Linux
php enable on my server - 4 and above
mySql on server enable - latest (using default in my XOOPS data)

5
jensclas
Re: how to solve :Too many connections in file class/database/mysqldatabase.php line 74 ?

Found this FAQ - https://xoops.org/modules/smartfaq/faq.php?faqid=279

You have a bit of a problem on your hands - may need to do a complete check and repair on database. can you see how to do that through phpmyadmin? (or C panel if you have it)

6
macsite2006
Re: how to solve :Too many connections in file class/database/mysqldatabase.php line 74 ?

thanks Jens, I check all MySql data but not able to find out :P. Hope someone will give me correct resolution lolz

Login

Who's Online

47 user(s) are online (32 user(s) are browsing Support Forums)


Members: 0


Guests: 47


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits