1
Oraklet
Re: Problems with cloning of modules - redeclaration of function. in two different modules.
  • 2008/10/21 13:30

  • Oraklet

  • Just popping in

  • Posts: 7

  • Since: 2008/7/24


To Trabis!

Quote:
If you want you can email me the original module and I will try to make it clonable.


Please send me an e-mail adress so that I can return the module to You.

Send an empty mail to cholm@stageone.dk


Kind regards
Carsten



2
Oraklet
Re: Problems with cloning of modules - redeclaration of function. in two different modules.
  • 2008/10/21 13:05

  • Oraklet

  • Just popping in

  • Posts: 7

  • Since: 2008/7/24


Hi!

I'm using the include_once only in this case where the file is included.
And that's in every file in the module where it has to be included.

But thanks for the hint anyway.
I just seems to be stuck! :( You know tinkering with the code for a prolonged period... and still it seems like there is no way out!)


Kind regards.
Carsten



3
Oraklet
Problems with cloning of modules - redeclaration of function. in two different modules.
  • 2008/10/21 10:16

  • Oraklet

  • Just popping in

  • Posts: 7

  • Since: 2008/7/24


Hi!

I'm trying to do something presumable simple, but keeps running wild!

Please help me, I'm getting more and more frustrated!

I have this module Pages, works fine, no problem! I have modified it to a degree that it is almost automated under install, I'm customising the module so that I can call the module directory anything, ( using the $xoopsModule->dirname() everywhere there is a reference) That actually works with no problems at all! The only thing I have to do manually to this point is, in the .sql file to rename the table headers and names acordingly to the folder name, then it runs smoothly.

That works when ever I do install the module, under any given name. no errors!

If I copy that module folder (Pages to e.g. NewPages) and do the renaming in the .sql files.
In the install module part, I can install the new module, It goes to complete, and when I return to the main page it is blank.

I can then get any of them to work, by renaming the other folder to something lige (pages_) then the NewPages works, do I then change it back, same blank page, renaming NewPages to Newpages_ then Pages works fine.

I'm that far that I get an error message that a function can't be redeclared! Normally when I did programs earlyer on, I havent encountered this problem, the functions lies in the include directory in each individual folder, no calls to the others.

Why do I get this problem, It doesn't helps to rename the function in one of the modules together with where it is called from. så that i calls the right function.

Please help me, I have a deadline 31. of october!
Mail me for a zipped version of the modules, at cholm@stageone.dk, if You want to help, and want to see what errors there are.

Kind regards

Carsten Holm
Odense, Denmark



4
Oraklet
Re: Pages - an older module, that seems ok for my purpose! - allmost! :-?
  • 2008/10/16 10:50

  • Oraklet

  • Just popping in

  • Posts: 7

  • Since: 2008/7/24


Thanks! Now I just have to figure out how it works!

Eventually take a look at this site where I need this functionality.

http://www.stageone.dk

Kind regards

Carsten




5
Oraklet
Pages - an older module, that seems ok for my purpose! - allmost! :-?
  • 2008/10/16 8:00

  • Oraklet

  • Just popping in

  • Posts: 7

  • Since: 2008/7/24


Hi Xoopsers!

I have a question regarding multiple instances of modules!

I have this moifications made that i takes the dirname as prefix for using the database, And that works perfectly, I can give it any name as long as I also changes the .sql file acordingly.

Now it installs without any quirks an I can use it and it functions as expected.

Then I create a second module and renames the directory to e.g. pagespp, changes the .sql content acordingly.
Then goes into the admin/modules to install!
If i just installs the second instance of that module, things starts to go wrong, XOOPS gives a blank page, reports no errors, but returns just a blank page!

If I instead of just installing the second (pagespp) uninstall the first (pages) and then install (pagespp) No problem what so ever!

Please help me, I'm desperate I can't figure out where ther error is! I will gladly send a .zip, .rar, .tar, .gz file containing both moduledirectories, to any one that will try to help me out.

What I want to obtain by doing this, is to gain the advantages of multiple colabsable menus...

Ultimately I seek for a module that can do that, so the menu only opens and shows the sub menus for the given selected menu point. Maybe also for a third level... E.g.

Menu1
Menu2
__SubMenuA
__SubMenuB
__SubMenuC
____SubSubMenu1
______Page 1C1A
______Page 1C1B <--- Page selected to wiev! (shown in main div!
______..
______Paga 1C1(n)
____SubSubMenu1
____..
____SubSubMenu(n)
__SubMenuD
__..
__SubMenu(n)
Menu3
Menu4
..
Menu(n)

I hope That You get the picture of what I mean.

What Pages does now is:

Menu1
__Page 1A
__Page 1B
__..
__Page 1(n)

Not quite what is my need....

Do You have any idea to do the mods to the pages-module! or an alternative module that can do my stuff!

Kind regards

Carsten



6
Oraklet
Re: TimesheetXoops feature request and help to do something similar!
  • 2008/10/16 7:30

  • Oraklet

  • Just popping in

  • Posts: 7

  • Since: 2008/7/24


Menu problem solved. Updated serversoftware....

But still misses solutions, or hints of how to do something



7
Oraklet
TimesheetXoops feature request and help to do something similar!
  • 2008/7/24 7:46

  • Oraklet

  • Just popping in

  • Posts: 7

  • Since: 2008/7/24


TimesheetXoops configuration!

Hi!

I do have a small issue, actually I have two small issues!

1) I'd like to do some slight modifications to the Report generation, so that I'll be able to create reports from the 26. day of the month till the 25. of the next month.
This feature would be nice if it could be set in the configuration af the module. e.g. month start date.

2) When I have TimesheetXoops 1.23 installed, I do seem to do something wrong, because my menus on the left side (e.g. user menu and others) dissapear. How do I get it to display TimeSheetXoops in the center?

Please help me, thank You very much in advance

Kind regards
Carsten Holm




TopTop



Login

Who's Online

481 user(s) are online (57 user(s) are browsing Support Forums)


Members: 0


Guests: 481


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jul 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits