(1) 2 »
ghostrunner ghostrunner
  • Just popping in
  • Just popping in
  • Joined: 2005/6/10 17:49
  • Group: Registered Users
  • Posts: 23
  • Posted on: 2008/9/27 13:29
Site keeps showing login form #1
Hi.
I Can log in to my site, but when i click on anything it shows me the login form again. If I then type in my username and password. Then I follow the link.
But each time I do something on my site I have to login again.
I havte tried to repair my session table but it didn't help.

Im using XOOPS 2.3 Final

Anyone knows what i should do.
Marco Marco
  • Home away from home
  • Home away from home
  • Joined: 2004/3/15 9:40
  • From Lille (France)
  • Group: BANNED Users
  • Posts: 1256
  • Posted on: 2008/9/27 14:12
Re: Site keeps showing login form #2
make that test here
if everything is not red, that's the explanation
Do synergy or die.
ghostrunner ghostrunner
  • Just popping in
  • Just popping in
  • Joined: 2005/6/10 17:49
  • Group: Registered Users
  • Posts: 23
  • Posted on: 2008/9/28 6:48
Re: Site keeps showing login form #3
I'm not sure i understand you.
Just tryed something else.
Made a clean install of XOOPS 2.3 just with thadmin 1.1 installed. I couldn't logout so i tryed to delete the cookie in my browser. Then I was loged out.
Now I got the same problem again.
I login to my site. Works ok.
Then when i click on a link on my site i have to login again. My site is working i just have to login everytime i click on something.

This is very wierd, can anyone help me

Still using 2.3
Marco Marco
  • Home away from home
  • Home away from home
  • Joined: 2004/3/15 9:40
  • From Lille (France)
  • Group: BANNED Users
  • Posts: 1256
  • Posted on: 2008/9/28 6:56
Re: Site keeps showing login form #4
just read my previous post and make the test plz
and give the result
so i can help you
thanks
Do synergy or die.
ghostrunner ghostrunner
  • Just popping in
  • Just popping in
  • Joined: 2005/6/10 17:49
  • Group: Registered Users
  • Posts: 23
  • Posted on: 2008/9/28 7:21
Re: Site keeps showing login form #5
what test?? I dont have your username / password to logon there.
I just get a normal closed site logon page.


However i think i narrowed down the problem to my language files. When i use my danish languagefiles i get the problem. With standard languagefiles it works ok.

ghostrunner ghostrunner
  • Just popping in
  • Just popping in
  • Joined: 2005/6/10 17:49
  • Group: Registered Users
  • Posts: 23
  • Posted on: 2008/9/28 7:28
Re: Site keeps showing login form #6
The standard languagefiles are not encoded in utf-8.
My danish languagefiles are in utf-8. Because og speciel caracters in danish.
Can this have anything to do with the problem
ghostrunner ghostrunner
  • Just popping in
  • Just popping in
  • Joined: 2005/6/10 17:49
  • Group: Registered Users
  • Posts: 23
  • Posted on: 2008/9/28 13:54
Re: Site keeps showing login form #7
I now got it working by encoding the languagefiles in ANSI (Standard). I them had to use the HTML codes for the special caracters.
A little annoing, but if that's what it takes...
anderssk anderssk
  • Quite a regular
  • Quite a regular
  • Joined: 2006/3/21 10:50
  • From Copenhagen, Denmark
  • Group: Registered Users
  • Posts: 335
  • Posted on: 2008/9/28 16:15
Re: Site keeps showing login form #8
If you are using 2.3.0 the language files are standard encoded in UTF-8

The danish language files for 2.3.0 is not at www.xoops.dk.
The only online language files is for 2.3.0 Beta, and they are encoded in ANSI (Latin1)

So, unless You have translated them youselv ore change the encoding til UTF I think You have the wrong language files.

It works with HTML for special characters, but it's not the solution. Every time you download a new translation, you have to chance it to HTML

At the moment xoops.dk and xoops.no is moving all activity to xoopsnordic.org
We will have a bigger community there.
The first thing is to get the forum and download-section up running.
Then all files will be encoded in UTF

ghostrunner ghostrunner
  • Just popping in
  • Just popping in
  • Joined: 2005/6/10 17:49
  • Group: Registered Users
  • Posts: 23
  • Posted on: 2008/9/29 10:03
Re: Site keeps showing login form #9
I think im using the 2.3 Beta lang. files.
I just reencoded them myself from latin1 to utf-8. Because i got som funny characters.
But now i'm back with latin1 encoded, using html for special characters.
anderssk anderssk
  • Quite a regular
  • Quite a regular
  • Joined: 2006/3/21 10:50
  • From Copenhagen, Denmark
  • Group: Registered Users
  • Posts: 335
  • Posted on: 2008/9/29 11:22
Re: Site keeps showing login form #10
You have to be sure that the global.php is containing UTF-8

The file is located in ..\language\danish\global.php (and ..\language\english\global.php)

The content should be (around line 200)
Quote:

//%%%%% LANGUAGE SPECIFIC SETTINGS %%%%%
define('_CHARSET', 'UTF-8');
define('_LANGCODE', 'da');


If it is set to ISO-8859-1, and Your files is in UTF-8 - you will get a funny page with danish characters

How to effectively post a question in the Xoops forums? - Read here...
Design by: XOOPS UI/UX Team