xoops forums

redheadedrod

Home away from home
Posted on: 2011/10/3 14:24
redheadedrod
redheadedrod (Show more)
Home away from home
Posts: 1296
Since: 2008/2/26
#1

Xoops 2.5.3 - What will be updated?

Since 2.5.3 looks to update many systems that xoops depends on I am curious what is the list of things that will be added/upgraded?

phpmailer and smarty I know about. What other things are going to be included?

I assume that we will also be looking at removing any remaining depreciated code if any exists in the core.

I am working on changing the install script but that will be more for 2.6 although it should work fine for other versions of Xoops as well.

We should list other things here so they don't get missed by the core developers.

Rodney

redheadedrod

Home away from home
Posted on: 2011/10/3 14:29
redheadedrod
redheadedrod (Show more)
Home away from home
Posts: 1296
Since: 2008/2/26
#2

Re: Xoops 2.5.3 - What will be updated?

Starting with 2.5.3 I am thinking we should consider also including the basic modules but update them with the latest versions if not already done with 2.5.2. Simon (Wishcraft) has updated the profile module to include a few new options. If this module is bugfree I think it should be included as well? Only thing to mention is that I believe any included modules should be clear of any advertising for the writer of the module otherwise it should not be included. Proper credit of course should be given but display of any logos etc that are not xoops should not be included in any public module packs.

trabis

Core Developer
Posted on: 2011/10/3 14:31
trabis
trabis (Show more)
Core Developer
Posts: 2258
Since: 2006/9/1 1
#3

Re: Xoops 2.5.3 - What will be updated?

We are going to update jQuery also. Not sure if there formuss has anything else to update.

Quote:

redheadedrod wrote:

I assume that we will also be looking at removing any remaining depreciated code if any exists in the core.


We will be leaving that for 2.6 along with php5.3 strict mode compliance and classes re-factoring(xoopspersistableobjecthandler).

Quote:

I am working on changing the install script but that will be more for 2.6 although it should work fine for other versions of Xoops as well.


That will be good for 2.6, yes.