Fork me on GitHub
Get XOOPS XOOPSXOOPS FAQFAQ ForumsForums NewsNews ThemesThemes ModulesModules
New Posts New Topics All Posts All Forums Index General Modules Themes Development International XOOPS.org

Search

Donat-O-Meter

Make donations with PayPal!
Stats
Goal: $100.00
Due Date: Apr 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00

Learn XOOPS Core

Local Support

Advertisement

XOOPS Code hosted on SourceForge

Cumulus Tag Cloud

- 2 2.5 2.6 3.0 4 6 adslight Android AntiHarvesting AntiMalUser AntiSpam Apple Battlefield billige Blocks Bootstrap Captcha cell cent chronolabs CHUNG Clicks content CĂN demo docek download Dresses evden eve facebook Fat floor Food for free Gateway Google Guide herre Home Honeypot html5 Human HỘ IP iPhone jQuery List log Loss mobile module modules Monster new newbb news NHÀ online PARK phone PHP Prevention profile project Protector publisher RESIDENCE responsive review Rights rmcommon Room security Sentry site Smartphone Smarty Smoking Spam stem Studio support tag tdmcreate template The Theme themes User userlog weight xoops Xortify XPayment ZendFramework

New Users

Registering user

# 137287

Zafer

Welcome to XOOPS!




Bottom   Previous Topic   Next Topic  Register To Post

(1) 2 3 4 5 »


#1 Posted on: 2002/6/6 12:08 "Sorry, you do not have the permission to access this area...."
When I install a module, I have no problems when I'm logged in as me (the first webmaster). If I try to go in as anonymous or as logged in as any other person (even one that has webmaster access) they get the permissions error.

I followed the instructions, chmod'ing the cache directory and its contents the same way I have the other modules.

Anyone have any ideas?

Top

sgentzen
Just popping in
Just popping in
Joined:
2002/4/10 7:45
Group:
Registered Users
Posts: 1
(Show More) (Show Less)


#2 Posted on: 2002/6/6 12:18 Re: "Sorry, you do not have the permission to access this area...."
read past posts, go to admin sections -> groups -> and set permissions for your anonymous group (and registered users)

Top

kain
Just popping in
Just popping in
Joined:
2002/1/9 3:31
From Italy
Group:
Registered Users
Posts: 38
(Show More) (Show Less)


#3 Posted on: 2002/6/14 2:06 Re: Browser cache causing many problems?
I don't know if your problem has been solved, but I've also had many problems with that damn "Sorry..." message.

What I've found during my testing of XOOPS is that the browser is caching the "Sorry..." redirect page and I have to force the browser to refresh the page to make things work right.

For example, consider this scenario...
1. I set anonymous user permissions to the contacts module to off.
2. I logout and try to access the contacts module and get the old "Sorry, you don't have permissions..." message. Good so far.
3. Now I log back in and change the anonymous user permissions to the contacts module to on.
4. I logout and try to access the contacts module and still I get the "Sorry..." message. Not so good anymore.
5. Now, if I try to access the contacts module again, and I immediately press the browser refresh button before the browser can redirect me, I can get to the conacts module.

I think this browser caching issue is causing a lot of the problems that people are attributing to cookies. Also caching may be the cause of problems where it "appears" that updated settings are not taking effect.

Possible solutions to this may be to add a line to the page headers to prevent caching. Either...

<meta-http-equiv="Expires" content="Thursday, 10-Jan-69 00:00:00 GMT">

or <META HTTP-EQUIV="Expires" CONTENT="-1">

or <meta http-equiv="Pragma" content="no_cache">

or <META HTTP-EQUIV="Cache-Control" CONTENT="no cache">



Top

dscg
Just popping in
Just popping in
Joined:
2002/6/7 3:46
From California, USA
Group:
Registered Users
Posts: 9
(Show More) (Show Less)


#4 Posted on: 2002/6/14 2:41 Re: Browser cache causing many problems?
That makes me wonder if an "Expire" meta tag would help solve this problem. In other words if we put this code in the <HEAD> of the "Sorry..." redirect page:
<meta-http-equiv="Expires" content="Thursday, 10-Jan-69 00:00:00 GMT">
or
<META HTTP-EQUIV="Expires" CONTENT="-1">


This and other cache possibilities described at this link: The Open Web Application Security Project

(I should have read Steve's entire post... he just said that. Oh well).


<small>[ Edited by sunsnapper on 2002/6/13 23:46:02 ]</small>

Top

sunsnapper
Friend of XOOPS
Friend of XOOPS
Joined:
2002/4/10 10:12
Group:
Registered Users
Posts: 400
(Show More) (Show Less)


#5 Posted on: 2002/7/21 1:13 Re: Browser cache causing many problems?
I found the no-cache HTTP header commands for the browser not to cache pages in the header.php file in the XOOPS main directory. So browsers should not cache any XOOPS page that include the root header.php file.

However, there are instances where you may call the redirect_header() function BEFORE including the header.php file in the root directory. This commonly occurs when you check if the user is logged in at the start of your module code like this Quote:
if ( !$xoopsUser ) {redirect_header(...)}

include $xoopsConfig['xoops_url']."/header.php";
... continue with the module code...


The problem is that the redirect_header() function does not have the HTTP no-cache commands. Therefore, the browser caches the redirect page. This has caused me many problems with users not being able to access pages even when they have permission to do so.

My suggestion would be to include the PHP header() function with the no-cache and expire commands in the redirect_header() function as well.

Otherwise, you will need to go through all the files to makes sure that $xoopsConfig['$xoops_url']."/header.php" appear before your redirect_header() call to avoid browser cache problems.

Top

dscg
Just popping in
Just popping in
Joined:
2002/6/7 3:46
From California, USA
Group:
Registered Users
Posts: 9
(Show More) (Show Less)


#6 Posted on: 2002/9/15 8:25 Re: "Sorry, you do not have the permission to access this area...."
you can set the permission again by steps :
go to phpadmin
open your sql
go to xoops_modules
set the valua of isactive to 0 then go to the main site and login again

Top

Frankenstein
Just popping in
Just popping in
Joined:
2002/7/30 7:29
Group:
Registered Users
Posts: 2
(Show More) (Show Less)


#7 Posted on: 2002/9/18 19:18 Re: "Sorry, you do not have the permission to access this area...."
I really hope XOOPS fixes this in the near future.

Top

David_Topping
Just popping in
Just popping in
Joined:
2002/9/16 20:50
From Toronto, Canada
Group:
Registered Users
Posts: 16
(Show More) (Show Less)


#8 Posted on: 2002/9/20 9:44 Re: "Sorry, you do not have the permission to access this area...."
This happened to me last night ... what i did to fix it was edit the user grouping access rights and have the *culprit* module's block access rights checked.

hope this helps.

Top

perze
Just popping in
Just popping in
Joined:
2002/9/19 22:21
Group:
Registered Users
Posts: 1
(Show More) (Show Less)


#9 Posted on: 2002/9/20 13:52 Re: "Sorry, you do not have the permission to access this area...."
"Sorry, you do not have the permission to access this area...."
how can i edit this text? which php file. i want to add "register first"
i think som visitor don't know that requires registration only with that msg

Top

densma
Just popping in
Just popping in
Joined:
2002/8/2 8:30
Group:
Registered Users
Posts: 23
(Show More) (Show Less)


#10 Posted on: 2002/10/3 13:57 Re: "Sorry, you do not have the permission to access this area...."
I've been getting this error message when annonymous users try to access the forum. I've tried re-setting the chmod's and going into phpMyAdmin............. but, i'm relatively new at all of this, and nothing seems to be working...


help?

Top

basskitten
Just popping in
Just popping in
Joined:
2002/9/22 15:34
From illadelph
Group:
Registered Users
Posts: 1
(Show More) (Show Less)




(1) 2 3 4 5 »



You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You can vote in polls.
You cannot attach files to posts.
You cannot post without approval.
You cannot use topic type.
You cannot use HTML syntax.
You cannot use signature.

[Advanced Search]