« 1 2 3 4 (5)
ipwgc ipwgc
  • Quite a regular
  • Quite a regular
  • Joined: 2005/8/13 1:08
  • From Chile
  • Group: Registered Users
  • Posts: 216
  • Posted on: 2012/12/23 13:18
Re: Oledrion 2.33 Beta 1 ready for testing on XOOPS 2.5.5 #41
Hi mamba,
I test this module oledrion in spanish, ['version'] = 2.33;
and I Traslate this new version in Spanish

THIS LITTHER BUG APPREAR
Fatal error: Cannot redeclare _PEAR_call_destructors() (previously declared in /xxxx/xxxxx/public_html/chile/modules/oledrion/class/PEAR.php:737) in /usr/lib/php/PEAR.php on line 777

THIS IS MY SETUP CONFIGURATION
Revisar configuraciónPHP mínimo requerido: 5.2 (su versión es 5.3.13)
MYSQL Versión mínima requerida: 5.0.7 (su versión es 5.5.28-cll)
Sistema minimo requerido: 2.5.5 (su versión es 2.5.5)
Mínimo ModuleAdmin requerido: 1.1 (su versión es 1.1)

HOW I FIXE BUG?
Resized Image
Mamba Mamba
  • Moderator
  • Moderator
  • Joined: 2004/4/23 14:58
  • From Ohio, USA
  • Group: Webmaster Registered Users Designer Group Super Moderator
  • Posts: 10293
  • Posted on: 2012/12/23 15:21
Re: Oledrion 2.33 Beta 1 ready for testing on XOOPS 2.5.5 #42
Quote:
Fatal error: Cannot redeclare _PEAR_call_destructors() (previously declared in /xxxx/xxxxx/public_html/chile/modules/oledrion/class/PEAR.php:737) in /usr/lib/php/PEAR.php on line 777

I am getting the same error in PHP 5.4.8, but it works fine with PHP 5.3.18, so it is kind of weird.

I'll probably remove the PEAR files, but it might take a week or two, before I get to Oledrion. So please be patient with us...

In the meantime, please test other modules from the recently updated Basic Module Pack
Please support XOOPS & DONATE
Use 2.5.8 | Debug | Requests | Bugs
redheadedrod redheadedrod
  • Home away from home
  • Home away from home
  • Joined: 2008/2/26 11:05
  • From Grand Rapids, MI
  • Group: Registered Users
  • Posts: 1296
  • Posted on: 2012/12/23 16:37
Re: Oledrion 2.33 Beta 1 ready for testing on XOOPS 2.5.5 #43
Some of the old modules use PEAR files that are not needed.. However you need to make sure that the installation HAS the needed pear module.

I have seen this in a few modules. You COULD probably just grab the latest version of that PEAR module and replace the current directory with it or just remove the pear module source from the module source tree and adjust any calls to call to the system pear calls.

PEAR wasn't a part of PHP until sometime into PHP5 and a number of the modules were written before PHP5 was in use.
Mamba Mamba
  • Moderator
  • Moderator
  • Joined: 2004/4/23 14:58
  • From Ohio, USA
  • Group: Webmaster Registered Users Designer Group Super Moderator
  • Posts: 10293
  • Posted on: 2013/2/5 11:50
Re: Oledrion 2.33 Beta 1 ready for testing on XOOPS 2.5.5 #44
Just a short update: I talked today to Voltan, and he did some improvements, so in few weeks we should expect an updated version from him.

I'll look into the PEAR issues and probably remove it, so we can be sure that we don't have any conflicts anymore.

The key is that Oledrion is not forgotten, and we are moving forward with it, thanks to Voltan.
Please support XOOPS & DONATE
Use 2.5.8 | Debug | Requests | Bugs
How to effectively post a question in the Xoops forums? - Read here...
Design by: XOOPS UI/UX Team