Fork me on GitHub
Get XOOPS XOOPSXOOPS FAQFAQ ForumsForums NewsNews ThemesThemes ModulesModules
New Posts New Topics All Posts All Forums Index General Modules Themes Development International XOOPS.org

Search

Learn XOOPS Core

Donat-O-Meter

Make donations with PayPal!
Stats
Goal: $100.00
Due Date: Sep 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00

Local Support

Advertisement

XOOPS Code hosted on SourceForge

Cumulus Tag Cloud

- 2 2.5 2.6 4 6 Abuse adslight Android AntiHarvesting AntiSpam API Apple Battlefield billige Blocks Bootstrap Captcha cell cent chronolabs CHUNG Clicks content CĂN demo docek download Dresses evden facebook Fat floor for free Gateway Google Guide herre Honeypot HP html5 Human HỘ iPhone jQuery Language List log Loss module modules Monster new newbb news NHÀ online PARK Payment phone PHP Prevention profile project Protector publisher RESIDENCE responsive review Rights rmcommon Room security Sentry site Smartphone Smarty Smoking Spam stem Studio support tag tags tdmcreate template The Theme themes User userlog web weight xoops Xortify XPayment ZendFramework

New Users

Registering user

# 137717

SLNK214324

Welcome to XOOPS!




Bottom   Previous Topic   Next Topic  Register To Post



#1 Posted on: 2012/12/23 5:39 Problem with pm module
After moving a site to a faster server the pm module is broken/gives a blank page. I tried reinstalling the module but get the error Executing xoops_module_update_pm failed. I re-uploaded the pm module files but without success... Updating other modules just works fine.

Debug shows many 'Unable to allocate memory for pool' errors and all over the site. Could there be a relation?

XOOPS 2.5.5
PHP 5.3.19
mySQL 5.3.5

Top


The Dutch speaking XOOPS community has moved!
____________________________________

For Dutch support now go to www.nlxoops.nl
flipse
Moderator
Moderator
Joined:
2005/9/15 4:11
From The Netherlands
Group:
Registered Users
Community Coordinator (temporary)
Posts: 746
(Show More) (Show Less)


#2 Posted on: 2012/12/23 6:10 Re: Problem with pm module
Quote:
Debug shows many 'Unable to allocate memory for pool' errors and all over the site. Could there be a relation?

It seems like the issue is related to APC ("Alternative PHP Cache") on your server.

Try to disable it, and test it again.

Top


Please support XOOPS & DONATE
Use 2.5.7 | Debugging | Requests | Bugs
Mamba
Moderator
Moderator
Joined:
2004/4/23 13:58
From Ohio, USA
Group:
Webmaster
Registered Users
Designer Group
Posts: 8041
(Show More) (Show Less)


#3 Posted on: 2012/12/23 9:53 Re: Problem with pm module
Thanks for your answer Michael, I was thinking about APC too. Have asked the hoster to disable it...

Top


The Dutch speaking XOOPS community has moved!
____________________________________

For Dutch support now go to www.nlxoops.nl
flipse
Moderator
Moderator
Joined:
2005/9/15 4:11
From The Netherlands
Group:
Registered Users
Community Coordinator (temporary)
Posts: 746
(Show More) (Show Less)


#4 Posted on: 2012/12/28 5:05 Re: Problem with pm module
APC is disabled now and the 'memory for pool' are gone, but the PM module is still mailfunctioning.

Ideas and suggestions are welcome!

Top


The Dutch speaking XOOPS community has moved!
____________________________________

For Dutch support now go to www.nlxoops.nl
flipse
Moderator
Moderator
Joined:
2005/9/15 4:11
From The Netherlands
Group:
Registered Users
Community Coordinator (temporary)
Posts: 746
(Show More) (Show Less)


#5 Posted on: 2012/12/28 6:19 Re: Problem with pm module
Quote:
PM module is still mailfunctioning.

Can you be more detailed?

Is it getting white pages? If yes, where? On the user side, or Admin?

Is it consistently on all links related to PM, or only on specific ones?

Top


Please support XOOPS & DONATE
Use 2.5.7 | Debugging | Requests | Bugs
Mamba
Moderator
Moderator
Joined:
2004/4/23 13:58
From Ohio, USA
Group:
Webmaster
Registered Users
Designer Group
Posts: 8041
(Show More) (Show Less)


#6 Posted on: 2012/12/28 6:35 Re: Problem with pm module
I managed to fix the problem. Removing the Dutch translation out of the PM folder did the trick, after that the module could be installed again.

I did some investigation and found an error in the Dutch translation. We'll have to update the local 2.5.5 Download on nlxoops!

Top


The Dutch speaking XOOPS community has moved!
____________________________________

For Dutch support now go to www.nlxoops.nl
flipse
Moderator
Moderator
Joined:
2005/9/15 4:11
From The Netherlands
Group:
Registered Users
Community Coordinator (temporary)
Posts: 746
(Show More) (Show Less)


#7 Posted on: 2012/12/28 6:57 Re: Problem with pm module
Fantastic! I'm glad that it is working now. But let us know about the translation issues, what was the problem, so we can learn from it for the future.

Top


Please support XOOPS & DONATE
Use 2.5.7 | Debugging | Requests | Bugs
Mamba
Moderator
Moderator
Joined:
2004/4/23 13:58
From Ohio, USA
Group:
Webmaster
Registered Users
Designer Group
Posts: 8041
(Show More) (Show Less)


#8 Posted on: 2012/12/28 7:09 Re: Problem with pm module
I found this error in /modules/pm/language/nederlands/main.php

define("_PM_EMAIL_DESC", "Beste %s, dit is een bericht doorgestuurd vanaf ".$GLOBALS[\'xoopsConfig\'][\'sitename\']);

I fixed it by removing some slashes:

define("_PM_EMAIL_DESC", "Beste %s, dit is een bericht doorgestuurd vanaf ".$GLOBALS['xoopsConfig']['sitename']);

The 2.5.5 download on nlxoops is fixed already!

Top


The Dutch speaking XOOPS community has moved!
____________________________________

For Dutch support now go to www.nlxoops.nl
flipse
Moderator
Moderator
Joined:
2005/9/15 4:11
From The Netherlands
Group:
Registered Users
Community Coordinator (temporary)
Posts: 746
(Show More) (Show Less)


#9 Posted on: 2012/12/28 8:02 Re: Problem with pm module
I did some more research, it seems related to the fact magic quotes are deprecated in php 5.3 and will be removed in php 5.4 .

Top


The Dutch speaking XOOPS community has moved!
____________________________________

For Dutch support now go to www.nlxoops.nl
flipse
Moderator
Moderator
Joined:
2005/9/15 4:11
From The Netherlands
Group:
Registered Users
Community Coordinator (temporary)
Posts: 746
(Show More) (Show Less)







You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.
You cannot use topic type.
You cannot use HTML syntax.
You cannot use signature.

[Advanced Search]