Anonymous  
Problem with pm module #1
After moving a site to a faster server the pm module is broken/gives a blank page. I tried reinstalling the module but get the error Executing xoops_module_update_pm failed. I re-uploaded the pm module files but without success... Updating other modules just works fine.

Debug shows many 'Unable to allocate memory for pool' errors and all over the site. Could there be a relation?

XOOPS 2.5.5
PHP 5.3.19
mySQL 5.3.5
Mamba Mamba
  • Moderator
  • Moderator
  • Joined: 2004/4/23 14:58
  • From Ohio, USA
  • Group: Webmaster Registered Users Designer Group Super Moderator
  • Posts: 10293
  • Posted on: 2012/12/23 7:10
Re: Problem with pm module #2
Quote:
Debug shows many 'Unable to allocate memory for pool' errors and all over the site. Could there be a relation?

It seems like the issue is related to APC ("Alternative PHP Cache") on your server.

Try to disable it, and test it again.
Please support XOOPS & DONATE
Use 2.5.8 | Debug | Requests | Bugs
Anonymous  
Re: Problem with pm module #3
Thanks for your answer Michael, I was thinking about APC too. Have asked the hoster to disable it...
Anonymous  
Re: Problem with pm module #4
APC is disabled now and the 'memory for pool' are gone, but the PM module is still mailfunctioning.

Ideas and suggestions are welcome!
Mamba Mamba
  • Moderator
  • Moderator
  • Joined: 2004/4/23 14:58
  • From Ohio, USA
  • Group: Webmaster Registered Users Designer Group Super Moderator
  • Posts: 10293
  • Posted on: 2012/12/28 7:19
Re: Problem with pm module #5
Quote:
PM module is still mailfunctioning.

Can you be more detailed?

Is it getting white pages? If yes, where? On the user side, or Admin?

Is it consistently on all links related to PM, or only on specific ones?
Please support XOOPS & DONATE
Use 2.5.8 | Debug | Requests | Bugs
Anonymous  
Re: Problem with pm module #6
I managed to fix the problem. Removing the Dutch translation out of the PM folder did the trick, after that the module could be installed again.

I did some investigation and found an error in the Dutch translation. We'll have to update the local 2.5.5 Download on nlxoops!
Mamba Mamba
  • Moderator
  • Moderator
  • Joined: 2004/4/23 14:58
  • From Ohio, USA
  • Group: Webmaster Registered Users Designer Group Super Moderator
  • Posts: 10293
  • Posted on: 2012/12/28 7:57
Re: Problem with pm module #7
Fantastic! I'm glad that it is working now. But let us know about the translation issues, what was the problem, so we can learn from it for the future.
Please support XOOPS & DONATE
Use 2.5.8 | Debug | Requests | Bugs
Anonymous  
Re: Problem with pm module #8
I found this error in /modules/pm/language/nederlands/main.php

define("_PM_EMAIL_DESC", "Beste %s, dit is een bericht doorgestuurd vanaf ".$GLOBALS[\'xoopsConfig\'][\'sitename\']);

I fixed it by removing some slashes:

define("_PM_EMAIL_DESC", "Beste %s, dit is een bericht doorgestuurd vanaf ".$GLOBALS['xoopsConfig']['sitename']);

The 2.5.5 download on nlxoops is fixed already!
Anonymous  
Re: Problem with pm module #9
I did some more research, it seems related to the fact magic quotes are deprecated in php 5.3 and will be removed in php 5.4 .
How to effectively post a question in the Xoops forums? - Read here...
Design by: XOOPS UI/UX Team